aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
commitb830ff89945d93e7dec4b46f9a38029b80f2c71c (patch)
tree9f391646f3e5cf12683bf4b82c0ad6168042d1cf /target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch
parent2fcc705fc5562b577cdded39e61ef725ee64d124 (diff)
downloadmaster-187ad058-b830ff89945d93e7dec4b46f9a38029b80f2c71c.tar.gz
master-187ad058-b830ff89945d93e7dec4b46f9a38029b80f2c71c.tar.bz2
master-187ad058-b830ff89945d93e7dec4b46f9a38029b80f2c71c.zip
preliminary 2.6.30 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch
new file mode 100644
index 0000000000..989e253d7c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/420-gpiodev.patch
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1016,6 +1016,13 @@ config CS5535_GPIO
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
+ config GPIO_VR41XX
+ tristate "NEC VR4100 series General-purpose I/O Unit support"
+ depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -94,6 +94,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o