aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-19 10:21:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-19 10:21:32 +0000
commitd021d0863b2e4f26afd3b42515dbb1dcbe2c6dbe (patch)
treefcf02474f03c99128400f6b1f6b166d4492367d3 /target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch
parent807811208caa9eb7591740893007484530493d42 (diff)
downloadmaster-187ad058-d021d0863b2e4f26afd3b42515dbb1dcbe2c6dbe.tar.gz
master-187ad058-d021d0863b2e4f26afd3b42515dbb1dcbe2c6dbe.tar.bz2
master-187ad058-d021d0863b2e4f26afd3b42515dbb1dcbe2c6dbe.zip
[kernel] remove 2.6.29 since there are no remaining users of it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15922 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch102
1 files changed, 0 insertions, 102 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch b/target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch
deleted file mode 100644
index c5aadd1ad1..0000000000
--- a/target/linux/generic-2.6/patches-2.6.29/902-darwin_scripts_include.patch
+++ /dev/null
@@ -1,102 +0,0 @@
---- a/scripts/genksyms/parse.c_shipped
-+++ b/scripts/genksyms/parse.c_shipped
-@@ -160,7 +160,9 @@
-
-
- #include <assert.h>
-+#ifndef __APPLE__
- #include <malloc.h>
-+#endif
- #include "genksyms.h"
-
- static int is_typedef;
---- a/scripts/genksyms/parse.y
-+++ b/scripts/genksyms/parse.y
-@@ -24,7 +24,9 @@
- %{
-
- #include <assert.h>
-+#ifndef __APPLE__
- #include <malloc.h>
-+#endif
- #include "genksyms.h"
-
- static int is_typedef;
---- a/scripts/kallsyms.c
-+++ b/scripts/kallsyms.c
-@@ -22,6 +22,35 @@
- #include <stdlib.h>
- #include <string.h>
- #include <ctype.h>
-+#ifdef __APPLE__
-+/* Darwin has no memmem implementation, this one is ripped of the uClibc-0.9.28 source */
-+void *memmem (const void *haystack, size_t haystack_len,
-+ const void *needle, size_t needle_len)
-+{
-+ const char *begin;
-+ const char *const last_possible
-+ = (const char *) haystack + haystack_len - needle_len;
-+
-+ if (needle_len == 0)
-+ /* The first occurrence of the empty string is deemed to occur at
-+ the beginning of the string. */
-+ return (void *) haystack;
-+
-+ /* Sanity check, otherwise the loop might search through the whole
-+ memory. */
-+ if (__builtin_expect (haystack_len < needle_len, 0))
-+ return NULL;
-+
-+ for (begin = (const char *) haystack; begin <= last_possible; ++begin)
-+ if (begin[0] == ((const char *) needle)[0] &&
-+ !memcmp ((const void *) &begin[1],
-+ (const void *) ((const char *) needle + 1),
-+ needle_len - 1))
-+ return (void *) begin;
-+
-+ return NULL;
-+}
-+#endif
-
- #define KSYM_NAME_LEN 128
-
---- a/scripts/kconfig/Makefile
-+++ b/scripts/kconfig/Makefile
-@@ -97,6 +97,9 @@ check-lxdialog := $(srctree)/$(src)/lxd
- # we really need to do so. (Do not call gcc as part of make mrproper)
- HOST_EXTRACFLAGS = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ccflags)
- HOST_LOADLIBES = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ldflags $(HOSTCC))
-+ifeq ($(shell uname -s),Darwin)
-+HOST_LOADLIBES += -lncurses
-+endif
-
- HOST_EXTRACFLAGS += -DLOCALE
-
---- a/scripts/mod/mk_elfconfig.c
-+++ b/scripts/mod/mk_elfconfig.c
-@@ -1,7 +1,11 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#ifndef __APPLE__
- #include <elf.h>
-+#else
-+#include "../../../../../tools/sstrip/include/elf.h"
-+#endif
-
- int
- main(int argc, char **argv)
---- a/scripts/mod/modpost.h
-+++ b/scripts/mod/modpost.h
-@@ -7,7 +7,11 @@
- #include <sys/mman.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#ifndef __APPLE__
- #include <elf.h>
-+#else
-+#include "../../../../../tools/sstrip/include/elf.h"
-+#endif
-
- #include "elfconfig.h"
-