aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
commit9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a (patch)
tree6527b3196b8418cb3359748a798c79644d18faf8 /target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
parent2c8109cadb574dc5db1b912a708933f1ff3baf56 (diff)
downloadmaster-187ad058-9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a.tar.gz
master-187ad058-9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a.tar.bz2
master-187ad058-9a3d875aac7e3011bb4cceb9f70c1d4fe65fd69a.zip
[kernel] revert 15922 - add back 2.6.29 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16127 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
new file mode 100644
index 0000000000..20be29221a
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/004-extra_optimization.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -560,6 +560,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+