aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-21 16:30:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-21 16:30:44 +0000
commite24e5420635f279acf7136d5690c4b82f4e970dc (patch)
tree9015a5fb3e3e954870b012caa2835b4276f60150 /target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch
parent754598ae7049c9b4922545fc98e0322b49a778a0 (diff)
downloadmaster-187ad058-e24e5420635f279acf7136d5690c4b82f4e970dc.tar.gz
master-187ad058-e24e5420635f279acf7136d5690c4b82f4e970dc.tar.bz2
master-187ad058-e24e5420635f279acf7136d5690c4b82f4e970dc.zip
remove support for ipp2p - it's unmaintained, broken, overmatching and undermatching => not that useful for QoS
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14596 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch b/target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch
index e377ca72a1..56b1de379a 100644
--- a/target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/140-netfilter_time.patch
@@ -204,11 +204,10 @@
+}
--- a/net/ipv4/netfilter/Kconfig
+++ b/net/ipv4/netfilter/Kconfig
-@@ -70,6 +70,22 @@ config IP_NF_MATCH_IPP2P
- help
- Module for matching traffic of various Peer-to-Peer applications
+@@ -92,6 +92,21 @@ config IP_NF_MATCH_ECN
+
+ To compile it as a module, choose M here. If unsure, say N.
-+
+config IP_NF_MATCH_TIME
+ tristate 'TIME match support'
+ depends on NETFILTER_ADVANCED
@@ -224,8 +223,8 @@
+ Documentation/modules.txt. If unsure, say `N'.
+
+
- config IP_NF_MATCH_ADDRTYPE
- tristate '"addrtype" address type match support'
+ config IP_NF_MATCH_TTL
+ tristate '"ttl" match support'
depends on NETFILTER_ADVANCED
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
@@ -235,5 +234,5 @@
obj-$(CONFIG_IP_NF_MATCH_SET) += ipt_set.o
+obj-$(CONFIG_IP_NF_MATCH_TIME) += ipt_time.o
- obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
-
+ # targets
+ obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o