aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-04-24 14:35:19 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-04-24 14:35:19 +0000
commit08e832b7f8ec1018b39eb8e8bc7cddc37c461155 (patch)
treefff548c19736b6ba88806ca170c45f245f905bbc /target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch
parent7477ccec2848a590bbfe8cd091a08fed2ea357f0 (diff)
downloadmaster-187ad058-08e832b7f8ec1018b39eb8e8bc7cddc37c461155.tar.gz
master-187ad058-08e832b7f8ec1018b39eb8e8bc7cddc37c461155.tar.bz2
master-187ad058-08e832b7f8ec1018b39eb8e8bc7cddc37c461155.zip
[kernel] remove 2.6.24, no target is relying on it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch
deleted file mode 100644
index 31d40c9449..0000000000
--- a/target/linux/generic-2.6/patches-2.6.24/410-gpio_buttons.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -183,4 +183,20 @@ config HP_SDC_RTC
- Say Y here if you want to support the built-in real time clock
- of the HP SDC controller.
-
-+config INPUT_GPIO_BUTTONS
-+ tristate "Polled GPIO buttons interface"
-+ depends on GENERIC_GPIO
-+ select INPUT_POLLDEV
-+ help
-+ This driver implements support for buttons connected
-+ to GPIO pins of various CPUs (and some other chips).
-+
-+ Say Y here if your device has buttons connected
-+ directly to such GPIO pins. Your board-specific
-+ setup logic must also provide a platform device,
-+ with configuration data saying which GPIOs are used.
-+
-+ To compile this driver as a module, choose M here: the
-+ module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -18,3 +18,4 @@ obj-$(CONFIG_INPUT_POWERMATE) += powerm
- obj-$(CONFIG_INPUT_YEALINK) += yealink.o
- obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.o
- obj-$(CONFIG_INPUT_UINPUT) += uinput.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o