aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/609-netfilter_string.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-01-06 19:28:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-01-06 19:28:07 +0000
commit19887d557e01aad2145fa3ad086bc12a8d04695a (patch)
tree58af9e3b3204308a2b7853127331f4d693e1b744 /target/linux/generic-2.4/patches/609-netfilter_string.patch
parent666f303b8f8a76ca44b62a58ae270d520944897b (diff)
downloadmaster-187ad058-19887d557e01aad2145fa3ad086bc12a8d04695a.tar.gz
master-187ad058-19887d557e01aad2145fa3ad086bc12a8d04695a.tar.bz2
master-187ad058-19887d557e01aad2145fa3ad086bc12a8d04695a.zip
update brcm-2.4 to 2.4.35.4, integrate new broadcom system code, update broadcom-wl to a contributed version (v4.150.10.5) - no bcm57xx support yet, will follow shortly
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10137 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.4/patches/609-netfilter_string.patch')
-rw-r--r--target/linux/generic-2.4/patches/609-netfilter_string.patch62
1 files changed, 35 insertions, 27 deletions
diff --git a/target/linux/generic-2.4/patches/609-netfilter_string.patch b/target/linux/generic-2.4/patches/609-netfilter_string.patch
index ed5353f7a9..1f13da2a2f 100644
--- a/target/linux/generic-2.4/patches/609-netfilter_string.patch
+++ b/target/linux/generic-2.4/patches/609-netfilter_string.patch
@@ -1,6 +1,7 @@
-diff -urN linux.old/include/linux/netfilter_ipv4/ipt_string.h linux.dev/include/linux/netfilter_ipv4/ipt_string.h
---- linux.old/include/linux/netfilter_ipv4/ipt_string.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/include/linux/netfilter_ipv4/ipt_string.h 2006-11-13 23:33:31.000000000 +0100
+Index: linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_string.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.4.35.4/include/linux/netfilter_ipv4/ipt_string.h 2007-12-15 05:20:08.388318268 +0100
@@ -0,0 +1,18 @@
+#ifndef _IPT_STRING_H
+#define _IPT_STRING_H
@@ -20,10 +21,11 @@ diff -urN linux.old/include/linux/netfilter_ipv4/ipt_string.h linux.dev/include/
+};
+
+#endif /*_IPT_STRING_H*/
-diff -urN linux.old/net/ipv4/netfilter/Config.in linux.dev/net/ipv4/netfilter/Config.in
---- linux.old/net/ipv4/netfilter/Config.in 2006-11-13 23:43:38.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/Config.in 2006-11-13 23:33:31.000000000 +0100
-@@ -52,6 +52,7 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/Config.in
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Config.in 2007-12-15 05:20:07.892290000 +0100
++++ linux-2.4.35.4/net/ipv4/netfilter/Config.in 2007-12-15 05:20:08.396318720 +0100
+@@ -63,6 +63,7 @@
fi
if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
dep_tristate ' Unclean match support (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_UNCLEAN $CONFIG_IP_NF_IPTABLES
@@ -31,9 +33,10 @@ diff -urN linux.old/net/ipv4/netfilter/Config.in linux.dev/net/ipv4/netfilter/Co
dep_tristate ' Owner match support (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_OWNER $CONFIG_IP_NF_IPTABLES
dep_tristate ' Layer 7 match support (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_LAYER7 $CONFIG_IP_NF_CONNTRACK
dep_mbool ' Layer 7 debugging output (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_LAYER7_DEBUG $CONFIG_IP_NF_MATCH_LAYER7
-diff -urN linux.old/net/ipv4/netfilter/ipt_string.c linux.dev/net/ipv4/netfilter/ipt_string.c
---- linux.old/net/ipv4/netfilter/ipt_string.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/ipt_string.c 2006-11-14 02:26:03.000000000 +0100
+Index: linux-2.4.35.4/net/ipv4/netfilter/ipt_string.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.4.35.4/net/ipv4/netfilter/ipt_string.c 2007-12-15 05:20:08.400318949 +0100
@@ -0,0 +1,99 @@
+/* String matching match for iptables
+ *
@@ -134,20 +137,22 @@ diff -urN linux.old/net/ipv4/netfilter/ipt_string.c linux.dev/net/ipv4/netfilter
+
+module_init(init);
+module_exit(fini);
-diff -urN linux.old/net/ipv4/netfilter/Makefile linux.dev/net/ipv4/netfilter/Makefile
---- linux.old/net/ipv4/netfilter/Makefile 2006-11-13 23:43:38.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/Makefile 2006-11-13 23:33:31.000000000 +0100
-@@ -107,6 +107,7 @@
+Index: linux-2.4.35.4/net/ipv4/netfilter/Makefile
+===================================================================
+--- linux-2.4.35.4.orig/net/ipv4/netfilter/Makefile 2007-12-15 05:20:07.900290454 +0100
++++ linux-2.4.35.4/net/ipv4/netfilter/Makefile 2007-12-15 05:20:08.400318949 +0100
+@@ -108,6 +108,7 @@
obj-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark.o
obj-$(CONFIG_IP_NF_MATCH_CONNTRACK) += ipt_conntrack.o
obj-$(CONFIG_IP_NF_MATCH_UNCLEAN) += ipt_unclean.o
+obj-$(CONFIG_IP_NF_MATCH_STRING) += ipt_string.o
obj-$(CONFIG_IP_NF_MATCH_TCPMSS) += ipt_tcpmss.o
obj-$(CONFIG_IP_NF_MATCH_LAYER7) += ipt_layer7.o
- obj-$(CONFIG_IP_NF_MATCH_CONNBYTES) += ipt_connbytes.o
-diff -urN linux.old/net/ipv4/netfilter/textsearch/textsearch.c linux.dev/net/ipv4/netfilter/textsearch/textsearch.c
---- linux.old/net/ipv4/netfilter/textsearch/textsearch.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/textsearch/textsearch.c 2006-11-14 02:31:47.000000000 +0100
+
+Index: linux-2.4.35.4/net/ipv4/netfilter/textsearch/textsearch.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.4.35.4/net/ipv4/netfilter/textsearch/textsearch.c 2007-12-15 05:20:08.400318949 +0100
@@ -0,0 +1,305 @@
+/*
+ * lib/textsearch.c Generic text search interface
@@ -454,9 +459,10 @@ diff -urN linux.old/net/ipv4/netfilter/textsearch/textsearch.c linux.dev/net/ipv
+ kfree(conf);
+}
+
-diff -urN linux.old/net/ipv4/netfilter/textsearch/textsearch.h linux.dev/net/ipv4/netfilter/textsearch/textsearch.h
---- linux.old/net/ipv4/netfilter/textsearch/textsearch.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/textsearch/textsearch.h 2006-11-14 02:11:59.000000000 +0100
+Index: linux-2.4.35.4/net/ipv4/netfilter/textsearch/textsearch.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.4.35.4/net/ipv4/netfilter/textsearch/textsearch.h 2007-12-15 05:20:08.400318949 +0100
@@ -0,0 +1,182 @@
+#ifndef __LINUX_TEXTSEARCH_H
+#define __LINUX_TEXTSEARCH_H
@@ -640,9 +646,10 @@ diff -urN linux.old/net/ipv4/netfilter/textsearch/textsearch.h linux.dev/net/ipv
+#endif /* __KERNEL__ */
+
+#endif
-diff -urN linux.old/net/ipv4/netfilter/textsearch/ts_bm.c linux.dev/net/ipv4/netfilter/textsearch/ts_bm.c
---- linux.old/net/ipv4/netfilter/textsearch/ts_bm.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/textsearch/ts_bm.c 2006-11-14 02:22:20.000000000 +0100
+Index: linux-2.4.35.4/net/ipv4/netfilter/textsearch/ts_bm.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.4.35.4/net/ipv4/netfilter/textsearch/ts_bm.c 2007-12-15 05:20:08.400318949 +0100
@@ -0,0 +1,190 @@
+/*
+ * lib/ts_bm.c Boyer-Moore text search implementation
@@ -834,9 +841,10 @@ diff -urN linux.old/net/ipv4/netfilter/textsearch/ts_bm.c linux.dev/net/ipv4/net
+{
+ textsearch_unregister(&bm_ops);
+}
-diff -urN linux.old/net/ipv4/netfilter/textsearch/ts_kmp.c linux.dev/net/ipv4/netfilter/textsearch/ts_kmp.c
---- linux.old/net/ipv4/netfilter/textsearch/ts_kmp.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux.dev/net/ipv4/netfilter/textsearch/ts_kmp.c 2006-11-14 02:22:04.000000000 +0100
+Index: linux-2.4.35.4/net/ipv4/netfilter/textsearch/ts_kmp.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.4.35.4/net/ipv4/netfilter/textsearch/ts_kmp.c 2007-12-15 05:20:08.404319178 +0100
@@ -0,0 +1,141 @@
+/*
+ * lib/ts_kmp.c Knuth-Morris-Pratt text search implementation