aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/609-netfilter_string.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
committerNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
commit15a54116650a302bbb3c1ac0c72bb830a3a9c032 (patch)
treef601d4a279252ccd44a732bed871dc3d590be61a /target/linux/generic-2.4/patches/609-netfilter_string.patch
parent288135971920592d9b3bc7c22c080fe43d88cdd4 (diff)
downloadmaster-187ad058-15a54116650a302bbb3c1ac0c72bb830a3a9c032.tar.gz
master-187ad058-15a54116650a302bbb3c1ac0c72bb830a3a9c032.tar.bz2
master-187ad058-15a54116650a302bbb3c1ac0c72bb830a3a9c032.zip
remove ipset support from core, it is now provided by xtables-addons from the packages feed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17844 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.4/patches/609-netfilter_string.patch')
-rw-r--r--target/linux/generic-2.4/patches/609-netfilter_string.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/generic-2.4/patches/609-netfilter_string.patch b/target/linux/generic-2.4/patches/609-netfilter_string.patch
index baec7b2371..87934eda74 100644
--- a/target/linux/generic-2.4/patches/609-netfilter_string.patch
+++ b/target/linux/generic-2.4/patches/609-netfilter_string.patch
@@ -21,7 +21,7 @@
+#endif /*_IPT_STRING_H*/
--- a/net/ipv4/netfilter/Config.in
+++ b/net/ipv4/netfilter/Config.in
-@@ -61,6 +61,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
+@@ -47,6 +47,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
fi
if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
dep_tristate ' Unclean match support (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_UNCLEAN $CONFIG_IP_NF_IPTABLES
@@ -133,7 +133,7 @@
+module_exit(fini);
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -99,6 +99,7 @@ obj-$(CONFIG_IP_NF_MATCH_STATE) += ipt_s
+@@ -87,6 +87,7 @@ obj-$(CONFIG_IP_NF_MATCH_STATE) += ipt_s
obj-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark.o
obj-$(CONFIG_IP_NF_MATCH_CONNTRACK) += ipt_conntrack.o
obj-$(CONFIG_IP_NF_MATCH_UNCLEAN) += ipt_unclean.o