aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax-2.6/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-06-17 02:53:53 +0000
committerJohn Crispin <blogic@openwrt.org>2007-06-17 02:53:53 +0000
commitf11bf0d9779495c0549f975b3c24e9ec70788094 (patch)
tree770d9f6e2ddddad265433dd18824a017b8753460 /target/linux/etrax-2.6/profiles
parent970c8f4dc0644b07330f68f5f17837f6eb9e15c9 (diff)
downloadmaster-187ad058-f11bf0d9779495c0549f975b3c24e9ec70788094.tar.gz
master-187ad058-f11bf0d9779495c0549f975b3c24e9ec70788094.tar.bz2
master-187ad058-f11bf0d9779495c0549f975b3c24e9ec70788094.zip
initial merge for vhdl support on the foxboard
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7652 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/etrax-2.6/profiles')
-rw-r--r--target/linux/etrax-2.6/profiles/100-generic.mk16
-rw-r--r--target/linux/etrax-2.6/profiles/101-vhdl-nofb.mk17
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/etrax-2.6/profiles/100-generic.mk b/target/linux/etrax-2.6/profiles/100-generic.mk
new file mode 100644
index 0000000000..9d0fc72f88
--- /dev/null
+++ b/target/linux/etrax-2.6/profiles/100-generic.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/default
+ NAME:=Normal (default)
+endef
+
+define Profile/default/Description
+ Normal Foxboard setup (no vhdl)
+endef
+$(eval $(call Profile,default))
+
diff --git a/target/linux/etrax-2.6/profiles/101-vhdl-nofb.mk b/target/linux/etrax-2.6/profiles/101-vhdl-nofb.mk
new file mode 100644
index 0000000000..620db4209a
--- /dev/null
+++ b/target/linux/etrax-2.6/profiles/101-vhdl-nofb.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/vhdl_no_fb
+ NAME:=FOXVHDL no fb
+# PACKAGES:=kmod-madwifi
+endef
+
+define Profile/vhdl_no_fb/Description
+ Setup the Foxboard for FOXVHDL support with no framebuffer
+endef
+$(eval $(call Profile,vhdl_no_fb))
+