aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cobalt/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-14 08:18:11 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-14 08:18:11 +0000
commit3ff8d89328dc13358b9c2d7e74eed49bab5df227 (patch)
treec0744296d3b3215c3bceb0549f8bd6313c1f84ac /target/linux/cobalt/image
parent4bfda49041a063641eed67799b1b2b5d0e49c7b3 (diff)
downloadmaster-187ad058-3ff8d89328dc13358b9c2d7e74eed49bab5df227.tar.gz
master-187ad058-3ff8d89328dc13358b9c2d7e74eed49bab5df227.tar.bz2
master-187ad058-3ff8d89328dc13358b9c2d7e74eed49bab5df227.zip
[cobalt] add support for cobalt microservers (mips-based)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15836 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cobalt/image')
-rw-r--r--target/linux/cobalt/image/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/cobalt/image/Makefile b/target/linux/cobalt/image/Makefile
new file mode 100644
index 0000000000..ff74961d05
--- /dev/null
+++ b/target/linux/cobalt/image/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))