aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit704e2ed39d4e157d0c24d4dc3a3078cbacc6505c (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/cns3xxx
parent5431c1983b51e4f69db63f5d5c94b2ed157e5374 (diff)
downloadmaster-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.gz
master-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.bz2
master-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx')
-rw-r--r--target/linux/cns3xxx/Makefile2
-rw-r--r--target/linux/cns3xxx/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
index 4e8d6115f7..96d6ab137c 100644
--- a/target/linux/cns3xxx/Makefile
+++ b/target/linux/cns3xxx/Makefile
@@ -22,7 +22,7 @@ define Target/Description
eg. the Gateworks Laguna family
endef
-KERNELNAME:="uImage"
+KERNELNAME:="zImage uImage"
DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 6f13fbaf60..7fa0b35e06 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define mkimage
- mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage-$(1)
+ mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage-$(1)
endef
define Image/Prepare