aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.10/025-smp_support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-31 23:40:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-31 23:40:49 +0000
commitac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c (patch)
tree7ab55c9bbc8e965f5f7289891155e94c73193b80 /target/linux/cns3xxx/patches-3.10/025-smp_support.patch
parenta6b0a98d84acdda7b12226e4e0c46d0ca9e2d4f0 (diff)
downloadmaster-187ad058-ac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c.tar.gz
master-187ad058-ac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c.tar.bz2
master-187ad058-ac2d571b7d8bdcf6f53c6c266fb02cfb9686e65c.zip
cns3xxx: update to linux 3.10
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41917 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/patches-3.10/025-smp_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.10/025-smp_support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/patches-3.10/025-smp_support.patch b/target/linux/cns3xxx/patches-3.10/025-smp_support.patch
new file mode 100644
index 0000000000..4d6e0cd129
--- /dev/null
+++ b/target/linux/cns3xxx/patches-3.10/025-smp_support.patch
@@ -0,0 +1,30 @@
+--- a/arch/arm/mach-cns3xxx/Makefile
++++ b/arch/arm/mach-cns3xxx/Makefile
+@@ -5,3 +5,5 @@ cns3xxx-y += core.o pm.o
+ cns3xxx-$(CONFIG_ATAGS) += devices.o
+ cns3xxx-$(CONFIG_PCI) += pcie.o
+ cns3xxx-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
++cns3xxx-$(CONFIG_SMP) += platsmp.o headsmp.o
++cns3xxx-$(CONFIG_HOTPLUG_CPU) += hotplug.o
+--- a/arch/arm/mach-cns3xxx/Kconfig
++++ b/arch/arm/mach-cns3xxx/Kconfig
+@@ -6,6 +6,9 @@ config ARCH_CNS3XXX
+ select MIGHT_HAVE_CACHE_L2X0
+ select MIGHT_HAVE_PCI
+ select PCI_DOMAINS if PCI
++ select HAVE_ARM_SCU if SMP
++ select HAVE_ARM_TWD if LOCAL_TIMERS
++ select HAVE_SMP
+ help
+ Support for Cavium Networks CNS3XXX platform.
+
+--- a/arch/arm/mach-cns3xxx/core.h
++++ b/arch/arm/mach-cns3xxx/core.h
+@@ -11,6 +11,7 @@
+ #ifndef __CNS3XXX_CORE_H
+ #define __CNS3XXX_CORE_H
+
++extern struct smp_operations cns3xxx_smp_ops;
+ extern void cns3xxx_timer_init(void);
+
+ #ifdef CONFIG_CACHE_L2X0