aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-13 16:39:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-13 16:39:33 +0000
commit7dffa4a696dacc09d3d8ca37504a3f0a2ec92c9d (patch)
tree0872cb3e4f6dd6f4d7e4c9b51c57efa48419b06f /target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch
parent4bb1ea5172d3e0988b0016c4209e903734563384 (diff)
downloadmaster-187ad058-7dffa4a696dacc09d3d8ca37504a3f0a2ec92c9d.tar.gz
master-187ad058-7dffa4a696dacc09d3d8ca37504a3f0a2ec92c9d.tar.bz2
master-187ad058-7dffa4a696dacc09d3d8ca37504a3f0a2ec92c9d.zip
cns21xx: add support for 3.10
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37971 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch')
-rw-r--r--target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch b/target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch
new file mode 100644
index 0000000000..db0b080cb3
--- /dev/null
+++ b/target/linux/cns21xx/patches-3.10/003-arm-introduce-fa-platform.patch
@@ -0,0 +1,47 @@
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -1028,10 +1028,15 @@ source "arch/arm/mach-w90x900/Kconfig"
+
+ source "arch/arm/mach-zynq/Kconfig"
+
++source "arch/arm/plat-fa/Kconfig"
++
+ # Definitions to make life easier
+ config ARCH_ACORN
+ bool
+
++config PLAT_FA
++ bool
++
+ config PLAT_IOP
+ bool
+ select GENERIC_CLOCKEVENTS
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -205,6 +205,7 @@ machine-$(CONFIG_ARCH_SUNXI) += sunxi
+ plat-$(CONFIG_ARCH_OMAP) += omap
+ plat-$(CONFIG_ARCH_S3C64XX) += samsung
+ plat-$(CONFIG_PLAT_IOP) += iop
++plat-$(CONFIG_PLAT_FA) += fa
+ plat-$(CONFIG_PLAT_ORION) += orion
+ plat-$(CONFIG_PLAT_PXA) += pxa
+ plat-$(CONFIG_PLAT_S3C24XX) += samsung
+--- /dev/null
++++ b/arch/arm/plat-fa/Makefile
+@@ -0,0 +1,10 @@
++#
++# Makefile for the linux kernel.
++#
++
++obj-y :=
++
++obj-m :=
++obj-n :=
++obj- :=
++
+--- /dev/null
++++ b/arch/arm/plat-fa/Kconfig
+@@ -0,0 +1,3 @@
++if PLAT_FA
++
++endif