aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-02 10:23:45 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-02 10:23:45 +0000
commitf395ee2378c4b4dbbbf93625af479b608365b54c (patch)
tree38a57f4ec200a04463dfb48bf4b9beb4e26e4ebd /target/linux/brcm63xx
parent5c71763ccfa5cde01a510c9007718cd0114a18a7 (diff)
downloadmaster-187ad058-f395ee2378c4b4dbbbf93625af479b608365b54c.tar.gz
master-187ad058-f395ee2378c4b4dbbbf93625af479b608365b54c.tar.bz2
master-187ad058-f395ee2378c4b4dbbbf93625af479b608365b54c.zip
brcm63xx: fix livebox image generation
Livebox does need the uncompressed kernel, so just create it during image generation. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45875 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index cb9bf271dd..a4889c23f5 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -94,6 +94,7 @@ endef
define Image/Build/RedBootDTB
# Prepare kernel and rootfs
+ cat $(KDIR)/vmlinux $(DTS_DIR)/$(3).dtb > $(KDIR)/vmlinux-$(3)
gzip -9 -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
dd if=$(KDIR)/vmlinux-$(3).bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-vmlinux.gz bs=65536 conv=sync
dd if=$(KDIR)/root.squashfs of="$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs" bs=64k conv=sync
@@ -121,6 +122,7 @@ define Image/Build/RedBootDTB
"$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs" \
> "$(BIN_DIR)/$(IMG_PREFIX)-$(2)-redboot.bin"
rm -f $(BIN_DIR)/redbootscript $(BIN_DIR)/redbootscript.padded
+ rm -f $(KDIR)/vmlinux-$(3)
endef
define Image/Build/HCSDTB