aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-06-18 15:00:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-06-18 15:00:32 +0000
commite951c62e476570afdcf01240a435c103086898d0 (patch)
treeff4d42509be33741af78d7c42fdadec72a2d1cf5 /target/linux/brcm63xx
parent72b6e528a20cf7d3a7ef1de3dc9bb988cf4d225d (diff)
downloadmaster-187ad058-e951c62e476570afdcf01240a435c103086898d0.tar.gz
master-187ad058-e951c62e476570afdcf01240a435c103086898d0.tar.bz2
master-187ad058-e951c62e476570afdcf01240a435c103086898d0.zip
[brcm63xx] add imagetag support for BT Voyager 2500V, patch from Daniel Dickinson (#5364)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16506 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm_tag.h2
-rw-r--r--target/linux/brcm63xx/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm_tag.h b/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm_tag.h
index a4f06f8329..c06f668942 100644
--- a/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm_tag.h
+++ b/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm_tag.h
@@ -128,7 +128,7 @@ struct bcm_tag_bc221 {
unsigned char rootAddress[ADDRESS_LEN]; // 170-181: Address in memory of rootfs partition
unsigned char rootLength[IMAGE_LEN]; // 182-191: Size of rootfs partition
unsigned char flashLayoutVer[4]; // 192-195: Version flash layout
- unsigned char kernelCRC[4]; // 196-199: Guessed to be kernel CRC
+ unsigned char fskernelCRC[4]; // 196-199: Guessed to be kernel CRC
unsigned char reserved4[16]; // 200-215: Reserved area; unused at present
unsigned char imageCRC[4]; // 216-219: CRC32 of images
unsigned char reserved2[12]; // 220-231: Unused at present
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index c10a41b10b..515caeaa4a 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -101,7 +101,7 @@ define Image/Build
$(call Image/Build/CFE,$(1),96345GW2,6345,bc221,,bc221,-y 5)
$(call Image/Build/CFE,$(1),96345GW2,6345,bc300,,bc300,)
$(call Image/Build/CFE,$(1),96345GW2,6345,bc310,OpenWRT-$(REVISION),bc310,)
- $(call Image/Build/CFE,$(1),96348GW,6348,bccfe,,bcfe,)
+ $(call Image/Build/CFE,$(1),96348GW,6348,bccfe,,bccfe,)
$(call Image/Build/CFE,$(1),96348GW,6348,bc221,,bc221,-y 5)
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,bc221,,btvgr,-y 5)