aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2016-06-27 15:59:21 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-27 15:59:21 +0200
commitcf61ca6d699d5407a16ddaa9125a51db09428407 (patch)
treeac5590b05b7863aae16159fbf58e1292d4fe1149 /target/linux/brcm63xx
parent0a0b7425da48067c7ac613026f54659bb084d37c (diff)
downloadmaster-187ad058-cf61ca6d699d5407a16ddaa9125a51db09428407.tar.gz
master-187ad058-cf61ca6d699d5407a16ddaa9125a51db09428407.tar.bz2
master-187ad058-cf61ca6d699d5407a16ddaa9125a51db09428407.zip
brcm63xx: merge DSL-274X-F1 profiles
The only difference is a field in the image tag header, so just define two images for it instead of treating them as separate devices. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk22
1 files changed, 6 insertions, 16 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 80104f12e9..a4dd2feb9e 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -485,29 +485,19 @@ define Device/DSL274XB-C3
endef
TARGET_DEVICES += DSL274XB-C3
-define Device/DSL274XB-F1-AU
+define Device/DSL274XB-F1
$(Device/bcm63xx)
- DEVICE_TITLE := D-Link DSL-2740B/DSL-2741B rev F1 (AU)
+ DEVICE_TITLE := D-Link DSL-2740B/DSL-2741B rev F1
DEVICE_DTS := dsl-274xb-f
CFE_BOARD_ID := AW4339U
CFE_CHIP_ID := 6328
- CFE_EXTRAS := --signature2 "4.06.01.AUF1" --pad 4
+ IMAGES := cfe-EU.bin cfe-AU.bin
+ IMAGE/cfe-AU.bin := cfe-bin --signature2 "4.06.01.AUF1" --pad 4
+ IMAGE/cfe-EU.bin := cfe-bin --signature2 "4.06.01.EUF1" --pad 4
DEVICE_PACKAGES := \
$(ATH9K_PACKAGES)
endef
-TARGET_DEVICES += DSL274XB-F1-AU
-
-define Device/DSL274XB-F1-EU
- $(Device/bcm63xx)
- DEVICE_TITLE := D-Link DSL-2740B/DSL-2741B rev F1 (EU)
- DEVICE_DTS := dsl-274xb-f
- CFE_BOARD_ID := AW4339U
- CFE_CHIP_ID := 6328
- CFE_EXTRAS := --signature2 "4.06.01.EUF1" --pad 4
- DEVICE_PACKAGES := \
- $(ATH9K_PACKAGES)
-endef
-TARGET_DEVICES += DSL274XB-F1-EU
+TARGET_DEVICES += DSL274XB-F1
define Device/DSL275XB-D1
$(Device/bcm63xx)