aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-11 11:36:59 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-11 11:36:59 +0000
commita030157d7689aef35516d90e036eea69860334b9 (patch)
treee955e6bf2a0478f42f2c2b4297221c6026ed59da /target/linux/brcm63xx
parentac01f9dc1d6b0e89ab8c33e9a95c0501b179792c (diff)
downloadmaster-187ad058-a030157d7689aef35516d90e036eea69860334b9.tar.gz
master-187ad058-a030157d7689aef35516d90e036eea69860334b9.tar.bz2
master-187ad058-a030157d7689aef35516d90e036eea69860334b9.zip
brcm63xx: add helpers for building cfe images with dtb
Add a helper for building images with dtb appended kernels. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42122 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 705515c88b..eb53c8c3c2 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -33,6 +33,8 @@ endef
TARGET_DTBS:=
+TARGET_IMAGES:=
+
define Image/Build/CFE
# Generate the tagged image
$(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
@@ -43,6 +45,16 @@ define Image/Build/CFE
$(6) $(7) $(8) $(9)
endef
+define Image/Build/CFEDTB
+ # Generate the tagged image
+ $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux-$(2).lzma.cfe -f $(KDIR)/root.$(1) \
+ --output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
+ --boardid $(3) --chipid $(4) --entry $(KERNEL_ENTRY) \
+ --load-addr $(LOADADDR) --rsa-signature "$(6)" \
+ --info1 "-$(call Image/LimitName16,$(5))" --info2 $(1) \
+ $(7) $(8) $(9) $(10)
+endef
+
define Image/Build/CFEFIXUP
# Generate the tagged image
$(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
@@ -208,6 +220,15 @@ define Image/Build/Initramfs
$(call Image/Build/HCS,initramfs,cvg834g,a020,0001,0022,$(KDIR)/vmlinux-initramfs)
endef
+define CfeImageDTB
+ define Image/Build/$(4)
+ $$(call Image/Build/CFEDTB,$$(1),$(1),$(2),$(3),$(4),$(5),$(6))
+ endef
+
+ TARGET_DTBS += $(1)
+ TARGET_IMAGES += $(4)
+endef
+
define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
# Various routers
@@ -359,6 +380,9 @@ define Image/Build
# Netgear CVG834G
$(call Image/Build/HCS,$(1),cvg834g,a020,0001,0022,$(KDIR)/vmlinux)
+ # build dtb image list
+ $(foreach image,$(TARGET_IMAGES),$(call Image/Build/$(image),$(1)))
+
ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(call Image/Build/Initramfs)
endif