aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-01 12:37:34 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-01 12:37:34 +0000
commit434a7398621ae6c4a82eb89287d4359da523b271 (patch)
tree164e58ca46294237152507b7e37c69b8c28f6b8b /target/linux/brcm63xx/image/Makefile
parent956a143cada0bc695dd0d8535bb6710df09d0969 (diff)
downloadmaster-187ad058-434a7398621ae6c4a82eb89287d4359da523b271.tar.gz
master-187ad058-434a7398621ae6c4a82eb89287d4359da523b271.tar.bz2
master-187ad058-434a7398621ae6c4a82eb89287d4359da523b271.zip
brcm63xx: delete uncompressed kernels after use
Delete the dtb appended, uncompressed kernels after having compressed them, so they don't end in the image builder. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45869 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image/Makefile')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 139a2e3076..cb9bf271dd 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -167,6 +167,7 @@ define Image/PrepareLoaderDTB
# append dtb to vmlinux, then build a standard LZMA loader
cat $(KDIR)/vmlinux$(1) $(DTS_DIR)/$(2).dtb > $(KDIR)/vmlinux$(1)-$(2)
$(call Image/PrepareLoader,$(1)-$(2),$(3),$(4))
+ rm -f $(KDIR)/vmlinux$(1)-$(2)
endef
define Image/PrepareCFELzmaKernel
@@ -198,6 +199,7 @@ define Image/PrepareCFELzmaKernelDTB
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
$(call Image/PrepareCFELzmaKernel,-$(1))
+ rm -f $(KDIR)/vmlinux-$(1)
endef
define Image/Prepare