aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-06-07 17:04:37 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-06-07 17:04:37 +0000
commit3b8f1d816cfbce122a23066550430d82063d5008 (patch)
treeebb25962161485bec5fdb272ab6865a0f4dcce1b /target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
parentd6e0aeefffc9c2f336a9b3324e6ef763410b3a77 (diff)
downloadmaster-187ad058-3b8f1d816cfbce122a23066550430d82063d5008.tar.gz
master-187ad058-3b8f1d816cfbce122a23066550430d82063d5008.tar.bz2
master-187ad058-3b8f1d816cfbce122a23066550430d82063d5008.zip
brcm47xx: remove old gpio and nvram interfaces
These were only used by broadcom-diag any more. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41048 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch')
-rw-r--r--target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch b/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
index 4cf6ee0832..f666cf36ca 100644
--- a/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
+++ b/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
@@ -5,10 +5,10 @@ out the configuration than the in kernel cfe config reader.
--- a/arch/mips/bcm47xx/Makefile
+++ b/arch/mips/bcm47xx/Makefile
-@@ -6,3 +6,4 @@
+@@ -5,3 +5,4 @@
+
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
obj-y += board.o buttons.o leds.o workarounds.o
- obj-y += gpio.o
+obj-y += cfe_env.o
--- /dev/null
+++ b/arch/mips/bcm47xx/cfe_env.c
@@ -294,13 +294,3 @@ out the configuration than the in kernel cfe config reader.
/* Look for name=value and return value */
var = &nvram_buf[sizeof(struct nvram_header)];
end = nvram_buf + sizeof(nvram_buf) - 2;
-@@ -221,6 +250,9 @@ char *nvram_get(const char *name)
- if (!nvram_buf[0])
- nvram_init();
-
-+ if (cfe_env)
-+ return cfe_env_get(nvram_buf, name);
-+
- /* Look for name=value and return value */
- var = &nvram_buf[sizeof(struct nvram_header)];
- end = nvram_buf + sizeof(nvram_buf) - 2;