aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-03-02 21:16:18 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-03-02 21:16:18 +0000
commite2509a6038c452dac374e7826156450128b45706 (patch)
tree7cba8db872ecc919db657ccae8cc6efa0b5307a8 /target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch
parent0000020d9ea7f8a896edcaab680d4f56619de897 (diff)
downloadmaster-187ad058-e2509a6038c452dac374e7826156450128b45706.tar.gz
master-187ad058-e2509a6038c452dac374e7826156450128b45706.tar.bz2
master-187ad058-e2509a6038c452dac374e7826156450128b45706.zip
brcm47xx: add support for kernel 2.6.33
Thanks to acoul and tripolar git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19955 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch')
-rw-r--r--target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch b/target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch
new file mode 100644
index 0000000000..307bc7b785
--- /dev/null
+++ b/target/linux/brcm47xx/patches-2.6.33/110-flash_map.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -325,6 +325,12 @@ config MTD_CFI_FLAGADM
+ Mapping for the Flaga digital module. If you don't have one, ignore
+ this setting.
+
++config MTD_BCM47XX
++ tristate "BCM47xx flash device"
++ depends on MIPS && MTD_CFI && BCM47XX
++ help
++ Support for the flash chips on the BCM947xx board.
++
+ config MTD_REDWOOD
+ tristate "CFI Flash devices mapped on IBM Redwood"
+ depends on MTD_CFI && ( REDWOOD_4 || REDWOOD_5 || REDWOOD_6 )
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o
+ obj-$(CONFIG_MTD_SC520CDP) += sc520cdp.o