aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-08 02:34:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-08 02:34:18 +0000
commit5f6a1db000c741d07f81e955919b0e420c0a87c1 (patch)
tree83ecf51f2e0471e80e7ee1e43340db25768c4c05 /target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
parentdc4d1dd12a9168cd49db359cde517f5dc181bfe6 (diff)
downloadmaster-187ad058-5f6a1db000c741d07f81e955919b0e420c0a87c1.tar.gz
master-187ad058-5f6a1db000c741d07f81e955919b0e420c0a87c1.tar.bz2
master-187ad058-5f6a1db000c741d07f81e955919b0e420c0a87c1.zip
update work in progress rewritten bcm947xx code. wifi and usb seem to be working, flash access still has problems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6276 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile')
-rw-r--r--target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
new file mode 100644
index 0000000000..9f85d225dd
--- /dev/null
+++ b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
@@ -0,0 +1,14 @@
+ssb-driver-chipcommon-y := driver_chipcommon/chipcommon.o
+ssb-driver-mips-$(CONFIG_BCM947XX) := driver_mips/mips.o
+ssb-driver-pci-$(CONFIG_SSB_DRIVER_PCICORE) := driver_pci/pcicore.o
+
+ssb-$(CONFIG_SSB_PCIHOST) += pci.o
+ssb-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
+
+obj-$(CONFIG_SSB) += ssb.o
+
+ssb-objs := core.o scan.o \
+ $(ssb-y) $(ssb-m) \
+ $(ssb-driver-chipcommon-y) \
+ $(ssb-driver-mips-y) \
+ $(ssb-driver-pci-y)