aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
commitbbf13d61b7377b5114d9c716b7326f3f2bc468c1 (patch)
tree49c57d1eb3a67cf87f3072d933bda0faff33973d /target/linux/brcm2708/image
parente0d21348b5527b507648cd87898501eade36a94f (diff)
downloadmaster-187ad058-bbf13d61b7377b5114d9c716b7326f3f2bc468c1.tar.gz
master-187ad058-bbf13d61b7377b5114d9c716b7326f3f2bc468c1.tar.bz2
master-187ad058-bbf13d61b7377b5114d9c716b7326f3f2bc468c1.zip
image.mk: store the device name variable
Make the device name accessible for any build commands instead of forcing targets to define it themselves. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 2afd29b592..76e0abff1d 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -61,10 +61,9 @@ define Device/Default
IMAGES := sdcard.bin
IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
DEVICE_PROFILE :=
- DEVICE_NAME :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# $(1) = profile
# $(2) = image name
@@ -72,7 +71,6 @@ DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
define add_bcm2708
define Device/$(2)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)