aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-06-22 14:53:49 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-22 14:53:49 +0200
commit9cc73342cdb8e006df8cfcf669041c5e24ae08fb (patch)
tree464d13738da3f1cfa848cb5b4c03b887898f74d1 /target/linux/brcm2708/image
parent906ce8b22a737a5f880f5f21214580e9f04305b8 (diff)
downloadmaster-187ad058-9cc73342cdb8e006df8cfcf669041c5e24ae08fb.tar.gz
master-187ad058-9cc73342cdb8e006df8cfcf669041c5e24ae08fb.tar.bz2
master-187ad058-9cc73342cdb8e006df8cfcf669041c5e24ae08fb.zip
bcm2708: explicitly check for SUBTARGET instead of using the device SUBTARGETS variable
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index e2228ef13d..e9cbd85270 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -53,25 +53,28 @@ endef
DEVICE_VARS += DEVICE_DTS
define Device/rpi
- SUBTARGETS := bcm2708
DEVICE_TITLE := Raspberry Pi B/B+/CM
DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
endef
-TARGET_DEVICES += rpi
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi
+endif
define Device/rpi-2
- SUBTARGETS := bcm2709
DEVICE_TITLE := Raspberry Pi 2 B
DEVICE_DTS := bcm2709-rpi-2-b
endef
-TARGET_DEVICES += rpi-2
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi-2
+endif
define Device/rpi-3
- SUBTARGETS := bcm2710
DEVICE_TITLE := Raspberry Pi 3 B
DEVICE_DTS := bcm2710-rpi-3-b
DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
endef
-TARGET_DEVICES += rpi-3
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi-3
+endif
$(eval $(call BuildImage))