aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-06-20 14:50:04 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-20 14:50:38 +0200
commit602bafecdbbbcb171dccae5ce07178e2c5a920d0 (patch)
tree3c4b40212dd90e6680be82ca323bb20c844bc16f /target/linux/brcm2708/image
parentd7863315dd05777620fd133bb6880674fd3a00bd (diff)
downloadmaster-187ad058-602bafecdbbbcb171dccae5ce07178e2c5a920d0.tar.gz
master-187ad058-602bafecdbbbcb171dccae5ce07178e2c5a920d0.tar.bz2
master-187ad058-602bafecdbbbcb171dccae5ce07178e2c5a920d0.zip
brcm2708: update to latest version
As usual these patches were extracted from the raspberry pi repo: https://github.com/raspberrypi/linux/commits/rpi-4.4.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile2
-rw-r--r--target/linux/brcm2708/image/config.txt17
2 files changed, 13 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 8cf83a4563..7d28af9e7d 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -32,7 +32,7 @@ define Build/boot-img
mcopy -i $@.boot $(word 1,$^) ::kernel.img
$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
mmd -i $@.boot ::/overlays
- mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
+ mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
endef
diff --git a/target/linux/brcm2708/image/config.txt b/target/linux/brcm2708/image/config.txt
index 75b1cab7af..8c96f1fe97 100644
--- a/target/linux/brcm2708/image/config.txt
+++ b/target/linux/brcm2708/image/config.txt
@@ -476,7 +476,14 @@
## Stop start.elf from filling in ATAGS (memory from 0x100) before
## launching kernel
##
-disable_commandline_tags=2
+#disable_commandline_tags=2
+
+## enable_uart
+## Enables or disables uart pin multiplexing
+## Raspberry Pi 1/2: if unset, uart is enabled by default
+## Raspberry Pi 3: if unset uart is disabled by default
+##
+enable_uart=1
## cmdline (string)
## Command line parameters. Can be used instead of cmdline.txt file
@@ -491,7 +498,7 @@ disable_commandline_tags=2
## kernel_address
## Address to load kernel.img file at
##
-kernel_address=0x8000
+#kernel_address=0x8000
## ramfsfile (string)
## ramfs file to load
@@ -515,21 +522,21 @@ kernel_address=0x8000
## device_tree_address
## Address to load device_tree at
##
-device_tree_address=0x100
+#device_tree_address=0x100
## init_uart_baud
## Initial uart baud rate.
##
## Default 115200
##
-init_uart_baud=115200
+#init_uart_baud=115200
## init_uart_clock
## Initial uart clock.
##
## Default 3000000 (3MHz)
##
-init_uart_clock=3000000
+#init_uart_clock=3000000
## init_emmc_clock
## Initial emmc clock, increasing this can speedup your SD-card.