aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 07:39:10 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 07:39:10 +0000
commit29547a4f3120b90b978526d3691e474c58c37532 (patch)
tree4025dcd5a6c7368b98e8e9d33896ac9c6dd1d303 /target/linux/brcm2708/image
parentc6912b7718809fed392bd183a65db27b68fe80de (diff)
downloadmaster-187ad058-29547a4f3120b90b978526d3691e474c58c37532.tar.gz
master-187ad058-29547a4f3120b90b978526d3691e474c58c37532.tar.bz2
master-187ad058-29547a4f3120b90b978526d3691e474c58c37532.zip
brcm2708: Implement sysupgrade
Implement sysupgrade for Raspberry Pi, similar to the way it is done on x86: The config files are saved in the boot partition and moved to where they are normally expected in preinit. Also add optional gzip compression for the SD card image, since this can save a lot of space (76M vs 6M), also similar to x86. Signed-off-by: Bruno Randolf <br1@einfach.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46347 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 10ecfdaef0..53716e0d77 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -40,6 +40,9 @@ endef
define Build/sdcard-img
./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ gzip -k -f9 $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img
+ endif
endef
### Device macros ###