aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-08 18:11:55 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-08 18:11:55 +0000
commit8b0324262436e17beada3ea3fece85aedd46a35a (patch)
treec56ccb0560a8c4487d255f6c7a88e1624f0e68c3 /target/linux/brcm2708/image/Makefile
parentfec0cd2931a4788c71bb7adc731fde34f16f2be5 (diff)
downloadmaster-187ad058-8b0324262436e17beada3ea3fece85aedd46a35a.tar.gz
master-187ad058-8b0324262436e17beada3ea3fece85aedd46a35a.tar.bz2
master-187ad058-8b0324262436e17beada3ea3fece85aedd46a35a.zip
brcm2708: add Raspberry Pi 3 support
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48967 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index f96dccb09f..8cf83a4563 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -57,7 +57,7 @@ DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# $(1) = profile
# $(2) = image name
# $(3) = dts
-define bcm270x
+define bcm27xx
define Device/$(2)
DEVICE_PROFILE := $(1)
DEVICE_DTS := $(3)
@@ -68,13 +68,19 @@ endef
### BCM2708/BCM2835 ###
ifeq ($(SUBTARGET),bcm2708)
# Raspberry Pi Models B/B+/CM
- $(eval $(call bcm270x,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
+ $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
endif
### BCM2709/BCM2836 ###
ifeq ($(SUBTARGET),bcm2709)
# Raspberry Pi 2 Model B
- $(eval $(call bcm270x,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+ $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+endif
+
+### BCM2710/BCM2837 ###
+ifeq ($(SUBTARGET),bcm2710)
+ # Raspberry Pi 3 Model B
+ $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
endif
$(eval $(call BuildImage))