aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/profiles/WL700GE.mk
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit593b560d9371a5203c60e7e3161d86a65c2b9bb1 (patch)
treef560743479e4aef6d9013643b9b26923cd248bc1 /target/linux/brcm-2.4/profiles/WL700GE.mk
parent6206e865143b2b17f2bdb9e9584e3259b7edc4f2 (diff)
downloadmaster-187ad058-593b560d9371a5203c60e7e3161d86a65c2b9bb1.tar.gz
master-187ad058-593b560d9371a5203c60e7e3161d86a65c2b9bb1.tar.bz2
master-187ad058-593b560d9371a5203c60e7e3161d86a65c2b9bb1.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm-2.4/profiles/WL700GE.mk')
-rw-r--r--target/linux/brcm-2.4/profiles/WL700GE.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/profiles/WL700GE.mk b/target/linux/brcm-2.4/profiles/WL700GE.mk
new file mode 100644
index 0000000000..9037327d2e
--- /dev/null
+++ b/target/linux/brcm-2.4/profiles/WL700GE.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL700GE
+ NAME:=WL-700gE
+ PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
+endef
+
+define Profile/WL700GE/Description
+ Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
+ and the utilities to create a new filesystem on the HDD
+endef
+$(eval $(call Profile,WL700GE))
+
+