aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-22 15:31:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-22 15:31:13 +0000
commit2c55674246b6f7600f86df516360f6e91fa11082 (patch)
tree4f0d9ddb998524a799908ecc74c5ba1e063d17c2 /target/linux/bcm53xx
parentfcc7d8f722c8803f1d7555fc27638c72ad6a561a (diff)
downloadmaster-187ad058-2c55674246b6f7600f86df516360f6e91fa11082.tar.gz
master-187ad058-2c55674246b6f7600f86df516360f6e91fa11082.tar.bz2
master-187ad058-2c55674246b6f7600f86df516360f6e91fa11082.zip
kernel: update 3.10 to 3.10.2
Also refresh 3.10 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37502 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/Makefile2
-rw-r--r--target/linux/bcm53xx/patches-3.10/0011-bcma-make-it-possible-to-select-SoC-support-without-.patch2
-rw-r--r--target/linux/bcm53xx/patches-3.10/0013-bcma-add-constants-for-new-ARM-based-SoCs.patch2
-rw-r--r--target/linux/bcm53xx/patches-3.10/0014-bcma-return-correct-error-code-when-bus-can-failed.patch2
4 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
index 7fe3162054..2af0da5484 100644
--- a/target/linux/bcm53xx/Makefile
+++ b/target/linux/bcm53xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
FEATURES:=squashfs usb pci pcie gpio
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
-LINUX_VERSION:=3.10.1
+LINUX_VERSION:=3.10.2
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/bcm53xx/patches-3.10/0011-bcma-make-it-possible-to-select-SoC-support-without-.patch b/target/linux/bcm53xx/patches-3.10/0011-bcma-make-it-possible-to-select-SoC-support-without-.patch
index 08757346b1..1059436ee6 100644
--- a/target/linux/bcm53xx/patches-3.10/0011-bcma-make-it-possible-to-select-SoC-support-without-.patch
+++ b/target/linux/bcm53xx/patches-3.10/0011-bcma-make-it-possible-to-select-SoC-support-without-.patch
@@ -14,7 +14,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/drivers/bcma/Kconfig
+++ b/drivers/bcma/Kconfig
-@@ -35,8 +35,14 @@ config BCMA_DRIVER_PCI_HOSTMODE
+@@ -36,8 +36,14 @@ config BCMA_DRIVER_PCI_HOSTMODE
PCI core hostmode operation (external PCI bus).
config BCMA_HOST_SOC
diff --git a/target/linux/bcm53xx/patches-3.10/0013-bcma-add-constants-for-new-ARM-based-SoCs.patch b/target/linux/bcm53xx/patches-3.10/0013-bcma-add-constants-for-new-ARM-based-SoCs.patch
index 10c1c40474..9789d72ae2 100644
--- a/target/linux/bcm53xx/patches-3.10/0013-bcma-add-constants-for-new-ARM-based-SoCs.patch
+++ b/target/linux/bcm53xx/patches-3.10/0013-bcma-add-constants-for-new-ARM-based-SoCs.patch
@@ -12,7 +12,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/include/linux/bcma/bcma.h
+++ b/include/linux/bcma/bcma.h
-@@ -188,6 +188,11 @@ struct bcma_host_ops {
+@@ -189,6 +189,11 @@ struct bcma_host_ops {
#define BCMA_PKG_ID_BCM5357 11
#define BCMA_CHIP_ID_BCM53572 53572
#define BCMA_PKG_ID_BCM47188 9
diff --git a/target/linux/bcm53xx/patches-3.10/0014-bcma-return-correct-error-code-when-bus-can-failed.patch b/target/linux/bcm53xx/patches-3.10/0014-bcma-return-correct-error-code-when-bus-can-failed.patch
index 04af9d4570..0fe1067a6e 100644
--- a/target/linux/bcm53xx/patches-3.10/0014-bcma-return-correct-error-code-when-bus-can-failed.patch
+++ b/target/linux/bcm53xx/patches-3.10/0014-bcma-return-correct-error-code-when-bus-can-failed.patch
@@ -10,7 +10,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/drivers/bcma/main.c
+++ b/drivers/bcma/main.c
-@@ -218,7 +218,7 @@ int bcma_bus_register(struct bcma_bus *b
+@@ -237,7 +237,7 @@ int bcma_bus_register(struct bcma_bus *b
err = bcma_bus_scan(bus);
if (err) {
bcma_err(bus, "Failed to scan: %d\n", err);