aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-3.14
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-12-07 21:53:20 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-12-07 21:53:20 +0000
commit270356800f2196d87243be36d430dbc8ecea9e12 (patch)
tree8bd2f3361723d677311a83854088de1f3366eb65 /target/linux/bcm53xx/patches-3.14
parentc84400428296994ba164dfe4ae98b7d431fa35de (diff)
downloadmaster-187ad058-270356800f2196d87243be36d430dbc8ecea9e12.tar.gz
master-187ad058-270356800f2196d87243be36d430dbc8ecea9e12.tar.bz2
master-187ad058-270356800f2196d87243be36d430dbc8ecea9e12.zip
kernel: update bcma and ssb to wireless-testing master-2014-12-05
This brings ssb and bcma to wireless-testing tag master-2014-12-05 In addition it also adds the ARM-BCM5301X-Add-IRQs-to-Broadcom-s-bus- axi-in-DTS-f.patch which adds the irq number in a way it is done in the mainline kernel. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43544 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/patches-3.14')
-rw-r--r--target/linux/bcm53xx/patches-3.14/046-ARM-BCM5301X-Add-IRQs-to-Broadcom-s-bus-axi-in-DTS-f.patch58
-rw-r--r--target/linux/bcm53xx/patches-3.14/047-ARM-BCM5301X-Add-buttons-for-Netgear-R6250.patch7
-rw-r--r--target/linux/bcm53xx/patches-3.14/121-bcma-get-irqs-from-dt.patch38
-rw-r--r--target/linux/bcm53xx/patches-3.14/130-ARM-BCM5301X-register-bcma-bus.patch108
-rw-r--r--target/linux/bcm53xx/patches-3.14/170-pcie2-bcma-add-new-PCIe2-driver-for-bcma.patch4
-rw-r--r--target/linux/bcm53xx/patches-3.14/304-ARM-BCM5301X-Switch-DT-files-to-gpio-keys-polled.patch13
-rw-r--r--target/linux/bcm53xx/patches-3.14/305-ARM-BCM5301X-Enable-ChipCommon-UART-serial-console.patch11
-rw-r--r--target/linux/bcm53xx/patches-3.14/320-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-900DHP.patch8
-rw-r--r--target/linux/bcm53xx/patches-3.14/420-mtd-bcm5301x_nand.patch17
9 files changed, 98 insertions, 166 deletions
diff --git a/target/linux/bcm53xx/patches-3.14/046-ARM-BCM5301X-Add-IRQs-to-Broadcom-s-bus-axi-in-DTS-f.patch b/target/linux/bcm53xx/patches-3.14/046-ARM-BCM5301X-Add-IRQs-to-Broadcom-s-bus-axi-in-DTS-f.patch
new file mode 100644
index 0000000000..35cd0ca90a
--- /dev/null
+++ b/target/linux/bcm53xx/patches-3.14/046-ARM-BCM5301X-Add-IRQs-to-Broadcom-s-bus-axi-in-DTS-f.patch
@@ -0,0 +1,58 @@
+From dec378827c4aaab6c46ecdd5fc2c3b3155d68743 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Wed, 24 Sep 2014 23:50:07 +0200
+Subject: [PATCH] ARM: BCM5301X: Add IRQs to Broadcom's bus-axi in DTS file
+
+IRQ support for Broadcom's bus-axi driver bcma was merged into John
+Linville's wireless tree and will show up in 3.19. This patch makes use
+of this feature in the DTS file for the the BCM5301X SoCs. I left the
+PCIe controller out, because this still needs some discussion.
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ arch/arm/boot/dts/bcm5301x.dtsi | 34 ++++++++++++++++++++++++++++++++++
+ 1 file changed, 34 insertions(+)
+
+--- a/arch/arm/boot/dts/bcm5301x.dtsi
++++ b/arch/arm/boot/dts/bcm5301x.dtsi
+@@ -101,6 +101,40 @@
+ #address-cells = <1>;
+ #size-cells = <1>;
+
++ #interrupt-cells = <1>;
++ interrupt-map-mask = <0x000fffff 0xffff>;
++ interrupt-map =
++ /* ChipCommon */
++ <0x00000000 0 &gic GIC_SPI 85 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* USB 2.0 Controller */
++ <0x00021000 0 &gic GIC_SPI 79 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* USB 3.0 Controller */
++ <0x00023000 0 &gic GIC_SPI 80 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* Ethernet Controller 0 */
++ <0x00024000 0 &gic GIC_SPI 147 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* Ethernet Controller 1 */
++ <0x00025000 0 &gic GIC_SPI 148 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* Ethernet Controller 2 */
++ <0x00026000 0 &gic GIC_SPI 149 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* Ethernet Controller 3 */
++ <0x00027000 0 &gic GIC_SPI 150 IRQ_TYPE_LEVEL_HIGH>,
++
++ /* NAND Controller */
++ <0x00028000 0 &gic GIC_SPI 64 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 1 &gic GIC_SPI 65 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 2 &gic GIC_SPI 66 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 3 &gic GIC_SPI 67 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 4 &gic GIC_SPI 68 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 5 &gic GIC_SPI 69 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 6 &gic GIC_SPI 70 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00028000 7 &gic GIC_SPI 71 IRQ_TYPE_LEVEL_HIGH>;
++
+ chipcommon: chipcommon@0 {
+ reg = <0x00000000 0x1000>;
+
diff --git a/target/linux/bcm53xx/patches-3.14/047-ARM-BCM5301X-Add-buttons-for-Netgear-R6250.patch b/target/linux/bcm53xx/patches-3.14/047-ARM-BCM5301X-Add-buttons-for-Netgear-R6250.patch
index 82aa11c5c4..2b9b900064 100644
--- a/target/linux/bcm53xx/patches-3.14/047-ARM-BCM5301X-Add-buttons-for-Netgear-R6250.patch
+++ b/target/linux/bcm53xx/patches-3.14/047-ARM-BCM5301X-Add-buttons-for-Netgear-R6250.patch
@@ -13,8 +13,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
arch/arm/boot/dts/bcm5301x.dtsi | 1 +
2 files changed, 26 insertions(+)
-diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
-index 58d999d..4ed7de1 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -66,4 +66,29 @@
@@ -47,8 +45,6 @@ index 58d999d..4ed7de1 100644
+ };
+ };
};
-diff --git a/arch/arm/boot/dts/bcm5301x.dtsi b/arch/arm/boot/dts/bcm5301x.dtsi
-index b7c4e9e..78aec62 100644
--- a/arch/arm/boot/dts/bcm5301x.dtsi
+++ b/arch/arm/boot/dts/bcm5301x.dtsi
@@ -9,6 +9,7 @@
@@ -59,6 +55,3 @@ index b7c4e9e..78aec62 100644
#include <dt-bindings/interrupt-controller/irq.h>
#include <dt-bindings/interrupt-controller/arm-gic.h>
#include "skeleton.dtsi"
---
-1.8.4.5
-
diff --git a/target/linux/bcm53xx/patches-3.14/121-bcma-get-irqs-from-dt.patch b/target/linux/bcm53xx/patches-3.14/121-bcma-get-irqs-from-dt.patch
deleted file mode 100644
index e38b5bc1c6..0000000000
--- a/target/linux/bcm53xx/patches-3.14/121-bcma-get-irqs-from-dt.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 6611afa6c49434780096cdf2c1028f0ac277f9bc Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Thu, 9 Jan 2014 19:40:14 +0100
-Subject: [PATCH v3 2/2] bcma: get IRQ numbers from dt
-
-It is not possible to auto detect the irq numbers used by the cores on
-an arm SoC. If bcma was registered with device tree it will search for
-some device tree nodes with the irq number and add it to the core
-configuration.
-
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- drivers/bcma/main.c | 49 ++++++++++++++++++++++++++++++++++++++++++++++++-
- 1 file changed, 48 insertions(+), 1 deletion(-)
-
---- a/drivers/bcma/main.c
-+++ b/drivers/bcma/main.c
-@@ -10,6 +10,7 @@
- #include <linux/platform_device.h>
- #include <linux/bcma/bcma.h>
- #include <linux/slab.h>
-+#include <linux/of_irq.h>
- #include <linux/of_address.h>
-
- MODULE_DESCRIPTION("Broadcom's specific AMBA driver");
-@@ -159,8 +160,10 @@ static void bcma_of_fill_device(struct p
- struct device_node *node;
-
- node = bcma_of_find_child_device(parent, core);
-- if (node)
-- core->dev.of_node = node;
-+ if (!node)
-+ return;
-+ core->dev.of_node = node;
-+ core->irq = irq_of_parse_and_map(node, 0);
- }
- #else
- static void bcma_of_fill_device(struct platform_device *parent,
diff --git a/target/linux/bcm53xx/patches-3.14/130-ARM-BCM5301X-register-bcma-bus.patch b/target/linux/bcm53xx/patches-3.14/130-ARM-BCM5301X-register-bcma-bus.patch
index 024123f9d3..4044b44ff2 100644
--- a/target/linux/bcm53xx/patches-3.14/130-ARM-BCM5301X-register-bcma-bus.patch
+++ b/target/linux/bcm53xx/patches-3.14/130-ARM-BCM5301X-register-bcma-bus.patch
@@ -9,7 +9,7 @@ Subject: [PATCH 07/17] ARM: BCM5301X: register bcma bus
--- a/arch/arm/boot/dts/bcm5301x.dtsi
+++ b/arch/arm/boot/dts/bcm5301x.dtsi
-@@ -94,18 +94,102 @@
+@@ -95,12 +95,23 @@
};
};
@@ -31,84 +31,36 @@ Subject: [PATCH 07/17] ARM: BCM5301X: register bcma bus
#size-cells = <1>;
+ sprom = <&sprom0>;
- chipcommon: chipcommon@0 {
- reg = <0x00000000 0x1000>;
-+ interrupts = <GIC_SPI 85 IRQ_TYPE_LEVEL_HIGH>;
+ #interrupt-cells = <1>;
+ interrupt-map-mask = <0x000fffff 0xffff>;
+@@ -108,6 +119,30 @@
+ /* ChipCommon */
+ <0x00000000 0 &gic GIC_SPI 85 IRQ_TYPE_LEVEL_HIGH>,
- gpio-controller;
- #gpio-cells = <2>;
- };
-+
-+ pcie@12000 {
-+ reg = <0x00012000 0x1000>;
-+ interrupts = <GIC_SPI 131 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 126 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 127 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 128 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 129 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 130 IRQ_TYPE_LEVEL_HIGH>;
-+ };
-+
-+ pcie@13000 {
-+ reg = <0x00013000 0x1000>;
-+ interrupts = <GIC_SPI 137 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 132 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 133 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 135 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 136 IRQ_TYPE_LEVEL_HIGH>;
-+ };
-+
-+ pcie@14000 {
-+ reg = <0x00014000 0x1000>;
-+ interrupts = <GIC_SPI 143 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 138 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 139 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 140 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 141 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 142 IRQ_TYPE_LEVEL_HIGH>;
-+ };
-+
-+ usb2@21000 {
-+ reg = <0x00021000 0x1000>;
-+ interrupts = <GIC_SPI 79 IRQ_TYPE_LEVEL_HIGH>;
-+ };
++ /* PCIe Controller 0 */
++ <0x00012000 0 &gic GIC_SPI 126 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00012000 1 &gic GIC_SPI 127 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00012000 2 &gic GIC_SPI 128 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00012000 3 &gic GIC_SPI 129 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00012000 4 &gic GIC_SPI 130 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00012000 5 &gic GIC_SPI 131 IRQ_TYPE_LEVEL_HIGH>,
+
-+ usb3@23000 {
-+ reg = <0x00023000 0x1000>;
-+ interrupts = <GIC_SPI 80 IRQ_TYPE_LEVEL_HIGH>;
-+ };
++ /* PCIe Controller 1 */
++ <0x00013000 0 &gic GIC_SPI 132 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00013000 1 &gic GIC_SPI 133 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00013000 2 &gic GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00013000 3 &gic GIC_SPI 135 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00013000 4 &gic GIC_SPI 136 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00013000 5 &gic GIC_SPI 137 IRQ_TYPE_LEVEL_HIGH>,
+
-+ ethernet@24000 {
-+ reg = <0x00024000 0x1000>;
-+ interrupts = <GIC_SPI 147 IRQ_TYPE_LEVEL_HIGH>;
-+ };
++ /* PCIe Controller 2 */
++ <0x00014000 0 &gic GIC_SPI 138 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00014000 1 &gic GIC_SPI 138 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00014000 2 &gic GIC_SPI 140 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00014000 3 &gic GIC_SPI 141 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00014000 4 &gic GIC_SPI 142 IRQ_TYPE_LEVEL_HIGH>,
++ <0x00014000 5 &gic GIC_SPI 143 IRQ_TYPE_LEVEL_HIGH>,
+
-+ ethernet@25000 {
-+ reg = <0x00025000 0x1000>;
-+ interrupts = <GIC_SPI 148 IRQ_TYPE_LEVEL_HIGH>;
-+ };
-+
-+ ethernet@26000 {
-+ reg = <0x00026000 0x1000>;
-+ interrupts = <GIC_SPI 149 IRQ_TYPE_LEVEL_HIGH>;
-+ };
-+
-+ ethernet@27000 {
-+ reg = <0x00027000 0x1000>;
-+ interrupts = <GIC_SPI 150 IRQ_TYPE_LEVEL_HIGH>;
-+ };
-+
-+ nand@28000 {
-+ reg = <0x00028000 0x1000>;
-+ interrupts = <GIC_SPI 64 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 65 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 66 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 67 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 68 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 69 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 70 IRQ_TYPE_LEVEL_HIGH>,
-+ <GIC_SPI 71 IRQ_TYPE_LEVEL_HIGH>;
-+ };
- };
- };
+ /* USB 2.0 Controller */
+ <0x00021000 0 &gic GIC_SPI 79 IRQ_TYPE_LEVEL_HIGH>,
+
diff --git a/target/linux/bcm53xx/patches-3.14/170-pcie2-bcma-add-new-PCIe2-driver-for-bcma.patch b/target/linux/bcm53xx/patches-3.14/170-pcie2-bcma-add-new-PCIe2-driver-for-bcma.patch
index 84e6c06f5f..1b6149f20f 100644
--- a/target/linux/bcm53xx/patches-3.14/170-pcie2-bcma-add-new-PCIe2-driver-for-bcma.patch
+++ b/target/linux/bcm53xx/patches-3.14/170-pcie2-bcma-add-new-PCIe2-driver-for-bcma.patch
@@ -17,7 +17,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/arch/arm/mach-bcm/Kconfig
+++ b/arch/arm/mach-bcm/Kconfig
-@@ -46,6 +46,7 @@ config ARCH_BCM_5301X
+@@ -45,6 +45,7 @@ config ARCH_BCM_5301X
select ARM_GLOBAL_TIMER
select CLKSRC_ARM_GLOBAL_TIMER_SCHED_CLOCK
select MIGHT_HAVE_PCI
@@ -120,7 +120,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+ struct pci_sys_data *sys = pdev->sysdata;
+ struct bcma_device *bdev = sys->private_data;
+
-+ return bdev->irq;
++ return bcma_core_irq(bdev, 5);
+}
+
+static u32 bcma_pcie2_cfg_base(struct bcma_device *bdev, int busno,
diff --git a/target/linux/bcm53xx/patches-3.14/304-ARM-BCM5301X-Switch-DT-files-to-gpio-keys-polled.patch b/target/linux/bcm53xx/patches-3.14/304-ARM-BCM5301X-Switch-DT-files-to-gpio-keys-polled.patch
index ca7582d168..b107fe378c 100644
--- a/target/linux/bcm53xx/patches-3.14/304-ARM-BCM5301X-Switch-DT-files-to-gpio-keys-polled.patch
+++ b/target/linux/bcm53xx/patches-3.14/304-ARM-BCM5301X-Switch-DT-files-to-gpio-keys-polled.patch
@@ -17,8 +17,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
-diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-index 5fc0fae..583720e 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -24,7 +24,7 @@
@@ -30,8 +28,6 @@ index 5fc0fae..583720e 100644
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
-diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
-index 05e80b1..70a1093 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -68,7 +68,7 @@
@@ -43,8 +39,6 @@ index 05e80b1..70a1093 100644
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
-diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
-index 12fc2a0..ac299a2 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -58,7 +58,7 @@
@@ -56,8 +50,6 @@ index 12fc2a0..ac299a2 100644
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
-diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
-index fb76378..934b244 100644
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -58,7 +58,7 @@
@@ -69,8 +61,6 @@ index fb76378..934b244 100644
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
-diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
-index bbb414f..d2aefef 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -24,7 +24,7 @@
@@ -82,6 +72,3 @@ index bbb414f..d2aefef 100644
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
---
-1.8.4.5
-
diff --git a/target/linux/bcm53xx/patches-3.14/305-ARM-BCM5301X-Enable-ChipCommon-UART-serial-console.patch b/target/linux/bcm53xx/patches-3.14/305-ARM-BCM5301X-Enable-ChipCommon-UART-serial-console.patch
index 7d90697c6c..c81e20ff4a 100644
--- a/target/linux/bcm53xx/patches-3.14/305-ARM-BCM5301X-Enable-ChipCommon-UART-serial-console.patch
+++ b/target/linux/bcm53xx/patches-3.14/305-ARM-BCM5301X-Enable-ChipCommon-UART-serial-console.patch
@@ -14,8 +14,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 10 ++++++++++
4 files changed, 40 insertions(+)
-diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-index 583720e..d472c36 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -23,6 +23,16 @@
@@ -35,8 +33,6 @@ index 583720e..d472c36 100644
gpio-keys {
compatible = "gpio-keys-polled";
#address-cells = <1>;
-diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
-index ac299a2..257d6da 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -23,6 +23,16 @@
@@ -56,8 +52,6 @@ index ac299a2..257d6da 100644
leds {
compatible = "gpio-leds";
-diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
-index 934b244..cad0e85 100644
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -23,6 +23,16 @@
@@ -77,8 +71,6 @@ index 934b244..cad0e85 100644
leds {
compatible = "gpio-leds";
-diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
-index d2aefef..f3a0326 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -23,6 +23,16 @@
@@ -98,6 +90,3 @@ index d2aefef..f3a0326 100644
gpio-keys {
compatible = "gpio-keys-polled";
#address-cells = <1>;
---
-1.8.4.5
-
diff --git a/target/linux/bcm53xx/patches-3.14/320-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-900DHP.patch b/target/linux/bcm53xx/patches-3.14/320-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-900DHP.patch
index 96c728dfb0..197869745d 100644
--- a/target/linux/bcm53xx/patches-3.14/320-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-900DHP.patch
+++ b/target/linux/bcm53xx/patches-3.14/320-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-900DHP.patch
@@ -13,8 +13,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
2 files changed, 37 insertions(+), 1 deletion(-)
create mode 100644 arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 64c8f3f..41e8455 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -55,7 +55,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@@ -27,9 +25,6 @@ index 64c8f3f..41e8455 100644
dtb-$(CONFIG_ARCH_BERLIN) += \
berlin2-sony-nsz-gs7.dtb \
berlin2cd-google-chromecast.dtb
-diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
-new file mode 100644
-index 0000000..5e4b3a9
--- /dev/null
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-900dhp.dts
@@ -0,0 +1,35 @@
@@ -68,6 +63,3 @@ index 0000000..5e4b3a9
+ };
+ };
+};
---
-1.8.4.5
-
diff --git a/target/linux/bcm53xx/patches-3.14/420-mtd-bcm5301x_nand.patch b/target/linux/bcm53xx/patches-3.14/420-mtd-bcm5301x_nand.patch
index 86c288d41e..0e03870883 100644
--- a/target/linux/bcm53xx/patches-3.14/420-mtd-bcm5301x_nand.patch
+++ b/target/linux/bcm53xx/patches-3.14/420-mtd-bcm5301x_nand.patch
@@ -22,7 +22,7 @@
nand-objs := nand_base.o nand_bbt.o
--- /dev/null
+++ b/drivers/mtd/nand/bcm_nand.c
-@@ -0,0 +1,1591 @@
+@@ -0,0 +1,1590 @@
+/*
+ * Nortstar NAND controller driver
+ * for Linux NAND library and MTD interface
@@ -1527,15 +1527,9 @@
+static int bcmnand_probe(struct bcma_device *core)
+{
+ struct device *dev = &core->dev;
-+ struct device_node *np = dev->of_node;
+ struct bcmnand_ctrl *ctrl;
+ int res, i, irq;
+
-+ if (!np) {
-+ pr_err("%s: no device tree node found\n", DRV_NAME);
-+ return -ENOENT;
-+ }
-+
+ ctrl = devm_kzalloc(dev, sizeof(*ctrl), GFP_KERNEL);
+ if (!ctrl)
+ return -ENOMEM;
@@ -1546,8 +1540,13 @@
+ ctrl->core = core;
+
+ /* Acquire all interrupt lines */
-+ for (i = 0; i < of_irq_count(np); i++) {
-+ irq = irq_of_parse_and_map(np, i);
++ for (i = 0; i < NANDC_IRQ_NUM; i++) {
++ irq = bcma_core_irq(core, i);
++ if (!irq) {
++ pr_err("%s: IRQ no available irq: %i (idx: %i)\n",
++ DRV_NAME, irq, i);
++ return res;
++ }
+ res = devm_request_irq(dev, irq, bcmnand_isr, 0, DRV_NAME, ctrl);
+ if (res < 0) {
+ pr_err("%s: problem requesting irq: %i (idx: %i)\n",