aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-09-22 08:37:18 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-09-22 08:37:18 +0000
commit85fbc8df3cdd033c83ee98da254c26d0c5acdd8a (patch)
tree7daa10a12f63de9f24e0e248781a72608594d854 /target/linux/bcm53xx/image
parentfc42765c6b64ea1abf4d13770123ff8a65a3a6c7 (diff)
downloadmaster-187ad058-85fbc8df3cdd033c83ee98da254c26d0c5acdd8a.tar.gz
master-187ad058-85fbc8df3cdd033c83ee98da254c26d0c5acdd8a.tar.bz2
master-187ad058-85fbc8df3cdd033c83ee98da254c26d0c5acdd8a.zip
bcm53xx: image: document arguments of various functions
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42645 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 2acf107b35..fd303c4e4b 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -13,12 +13,14 @@ define Image/Prepare
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
+# $(1): dts filename (also used for the firmware file).
define Image/Build/initramfs/DTB
$(call Image/Build/DTB,zImage-initramfs,$(1))
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-initramfs-$(1).trx \
-f $(KDIR)/zImage-initramfs-$(1).lzma
endef
+# $(1): dts filename (also used for the firmware file).
define Image/Build/squashfs/DTB
$(call Image/Build/DTB,zImage,$(1))
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-squashfs-$(1).trx \
@@ -26,6 +28,8 @@ define Image/Build/squashfs/DTB
-a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
endef
+# $(1): kernel (Linux) image file
+# $(2): dts filename (also used for the firmware file).
define Image/Build/DTB
rm -f $(KDIR)/$(1)-$(2).lzma
rm -f $(KDIR)/$(1)-$(2).dts
@@ -33,6 +37,10 @@ define Image/Build/DTB
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
endef
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+# $(3): board_id (device specific magic).
+# $(4): region.
define Image/Build/Chk
$(call Image/Build/$(1)/DTB,$(2))
$(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(1)-$(2).trx -b $(3) -r $(4)