aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-07-12 13:46:27 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-07-12 13:46:27 +0000
commit21201be1f4a0b915ef8c32ae34afefff58d4f42c (patch)
tree42e9e85c31ce67c40103d9267bda76e5fa957bf6 /target/linux/bcm53xx/image
parent089d2c0e73fb6cbcbedd7d1cfc03b183c7075fd9 (diff)
downloadmaster-187ad058-21201be1f4a0b915ef8c32ae34afefff58d4f42c.tar.gz
master-187ad058-21201be1f4a0b915ef8c32ae34afefff58d4f42c.tar.bz2
master-187ad058-21201be1f4a0b915ef8c32ae34afefff58d4f42c.zip
bcm53xx: add initial support for ARM based BCM47XX and BCM53XX SoCs
This was only tested on a Netgear R6250, but it could also work on other devices when the correct images are generated. It is only possible to boot into a ram disk, no Ethernet, Wifi, flash, USB is supported. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37268 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
new file mode 100644
index 0000000000..62544c6492
--- /dev/null
+++ b/target/linux/bcm53xx/image/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ rm -f $(KDIR)/fs_mark
+ echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
+ $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
+endef
+
+define Image/Build/Initramfs
+ $(call Image/Build/Initramfs/Chk,bcm5301-netgear-r6250,U12H245T00_NETGEAR,2,initramfs)
+endef
+
+define Image/Build/Initramfs/Chk
+ $(call Image/Build/Initramfs/DTB,$(1))
+ $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(1)-$(4).chk -k $(KDIR)/$(IMG_PREFIX)-$(4)-$(1).trx -b $(2) -r $(3)
+endef
+
+define Image/Build/Initramfs/DTB
+ $(call Image/Build/DTB,zImage-initramfs,$(1))
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-initramfs-$(1).trx \
+ -f $(KDIR)/zImage-initramfs-$(1).lzma
+endef
+
+define Image/Build/squashfs/DTB
+ $(call Image/Build/DTB,zImage,$(1))
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-squashfs-$(1).trx \
+ -f $(KDIR)/zImage-$(1).lzma \
+ -a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+endef
+
+define Image/Build/squashfs/Chk
+ $(call Image/Build/squashfs/DTB,$(1))
+ $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(1)-$(4).chk -k $(KDIR)/$(IMG_PREFIX)-$(4)-$(1).trx -b $(2) -r $(3)
+endef
+
+define Image/Build/DTB
+ rm -f $(KDIR)/$(1)-$(2).lzma
+ rm -f $(KDIR)/$(1)-$(2).dts
+ cat $(KDIR)/$(1) $(LINUX_DIR)/arch/$(ARCH)/boot/dts/$(2).dtb > $(KDIR)/$(1)-$(2).dts;
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+ $(call Image/Build/squashfs/Chk,bcm5301-netgear-r6250,U12H245T00_NETGEAR,2,squashfs)
+endef
+
+
+$(eval $(call BuildImage))