aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-05 01:01:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-05 01:01:27 +0000
commita30a98a57c690f76a54a6035b8f0a4687c068f81 (patch)
tree9befc21064cc1ed1b7ab375761f134a7f032e2cb /target/linux/avr32
parent4b47c62538417b6b7893b0de97f35cb124dd3fde (diff)
downloadmaster-187ad058-a30a98a57c690f76a54a6035b8f0a4687c068f81.tar.gz
master-187ad058-a30a98a57c690f76a54a6035b8f0a4687c068f81.tar.bz2
master-187ad058-a30a98a57c690f76a54a6035b8f0a4687c068f81.zip
only build avr32 u-boot if requested, fixes build failure in default config
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12116 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/avr32')
-rw-r--r--target/linux/avr32/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 2cef2653bf..c74efbe1df 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -8,13 +8,15 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+ define Build/Clean
$(MAKE) -C u-boot clean
-endef
+ endef
-define Build/Compile
+ define Build/Compile
$(MAKE) -C u-boot compile
-endef
+ endef
+endif
define Image/Prepare
cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage