aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32-2.6/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-06-08 10:44:01 +0000
commit15a51103e899264b1689fa9967c4f74c4417bca1 (patch)
treeab9aee6ffb779dd0147f55c0876d42e29802fe90 /target/linux/avr32-2.6/Makefile
parentd442289f60548d0c33385edd723ba2eb61cd88c5 (diff)
downloadmaster-187ad058-15a51103e899264b1689fa9967c4f74c4417bca1.tar.gz
master-187ad058-15a51103e899264b1689fa9967c4f74c4417bca1.tar.bz2
master-187ad058-15a51103e899264b1689fa9967c4f74c4417bca1.zip
add support for the AVR32 platform, namely the ATNGW100 board - joint work with wigyori
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7533 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/avr32-2.6/Makefile')
-rw-r--r--target/linux/avr32-2.6/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/avr32-2.6/Makefile b/target/linux/avr32-2.6/Makefile
new file mode 100644
index 0000000000..2dcd76a9b4
--- /dev/null
+++ b/target/linux/avr32-2.6/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=avr32
+BOARD:=avr32
+BOARDNAME:=Atmel AVR32
+FEATURES:=squashfs
+
+define Target/Description
+ Build firmware images for ATNGW100 board
+endef
+
+KERNEL:=2.6
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+#include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))