aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-18 18:30:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-18 18:30:29 +0000
commitad1b040137f05e9f23a99199b76df2fa414b9dd2 (patch)
treec5e50afcb841cad252bb66c7013748d2efb34a40 /target/linux/au1000-2.6/image
parentbe6b488973156846b3fca4cecd1bf0b138fc6c9f (diff)
downloadmaster-187ad058-ad1b040137f05e9f23a99199b76df2fa414b9dd2.tar.gz
master-187ad058-ad1b040137f05e9f23a99199b76df2fa414b9dd2.tar.bz2
master-187ad058-ad1b040137f05e9f23a99199b76df2fa414b9dd2.zip
some platform support path name cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5846 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/au1000-2.6/image')
-rw-r--r--target/linux/au1000-2.6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index c9ab7caca9..b5ba3d4542 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -21,7 +21,7 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE)
define Build/Clean
- $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
@@ -32,13 +32,13 @@ define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
# Build RAM image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
clean compile
$(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
# Build Flash image
- $(MAKE) -C ../../generic-2.6/image/lzma-loader \
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader \
$(LOADER_MAKEOPTS) \
IMAGE_COPY=1 \
LOADER_ENTRY=$(FLASH_KERNEL) \