aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-24 21:57:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-24 21:57:34 +0000
commit9558b6c1e426570689bccdc65c9a0716c62c17dc (patch)
tree8ad9264ab9e9a8f311e0c2d9fab719da71cd4d57 /target/linux/au1000-2.6/image
parent21222b3091f07b7a086aae12223d2d7d367aef7f (diff)
downloadmaster-187ad058-9558b6c1e426570689bccdc65c9a0716c62c17dc.tar.gz
master-187ad058-9558b6c1e426570689bccdc65c9a0716c62c17dc.tar.bz2
master-187ad058-9558b6c1e426570689bccdc65c9a0716c62c17dc.zip
Update au1000 for .21, build an SREC initramfs image so that it can be tested directly with yamon
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7333 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/au1000-2.6/image')
-rw-r--r--target/linux/au1000-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index b5ba3d4542..5b8c3cc0f0 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -48,12 +48,19 @@ define Image/Prepare
$(OBJCOPY_BIN) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.bin
endef
+define Image/Build/Initramfs
+ $(OBJCOPY_SREC) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.srec
+endef
+
define Image/Build
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma $(FLASH_FS) $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec
grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
$(CP) $(KDIR)/kernel.flash.bin $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.bin
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ $(call Image/Build/Initramfs)
+endif
endef
$(eval $(call BuildImage))