aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-11 17:55:39 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-11 17:55:39 +0000
commit639b2013ca05bb2e9bad05044d5cd5eb2e589eec (patch)
tree265c4e1774753c617fcc916cf0d111be442c767a /target/linux/au1000-2.6/Makefile
parent4145f168726318b1ed73bf7d13feaa7eabf14915 (diff)
downloadmaster-187ad058-639b2013ca05bb2e9bad05044d5cd5eb2e589eec.tar.gz
master-187ad058-639b2013ca05bb2e9bad05044d5cd5eb2e589eec.tar.bz2
master-187ad058-639b2013ca05bb2e9bad05044d5cd5eb2e589eec.zip
Add different Wi-Fi profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5761 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/au1000-2.6/Makefile')
-rw-r--r--target/linux/au1000-2.6/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/au1000-2.6/Makefile b/target/linux/au1000-2.6/Makefile
index 258990f8b7..45b718135d 100644
--- a/target/linux/au1000-2.6/Makefile
+++ b/target/linux/au1000-2.6/Makefile
@@ -28,5 +28,23 @@ define Kernel/BuildImage
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
endef
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/Intel
+ NAME:=Intel IPW2200 WiFi
+ PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
+define Profile/Broadcom
+ NAME:=Broadcom BCM43xx WiFi
+ PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
$(eval $(call BuildKernel))