aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-3.18/020-early-printk-support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:28 +0000
commit6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2 (patch)
treefc284dc684b04e5289b1046ec0c213b085faf214 /target/linux/atheros/patches-3.18/020-early-printk-support.patch
parentd057b4aae39c3b12d2ab141df88bc0f073d4c4b4 (diff)
downloadmaster-187ad058-6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2.tar.gz
master-187ad058-6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2.tar.bz2
master-187ad058-6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2.zip
Rename 'atheros' target to 'ath25'
Rename 'atheros' target to more precise 'ath25'. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44736 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/patches-3.18/020-early-printk-support.patch')
-rw-r--r--target/linux/atheros/patches-3.18/020-early-printk-support.patch68
1 files changed, 0 insertions, 68 deletions
diff --git a/target/linux/atheros/patches-3.18/020-early-printk-support.patch b/target/linux/atheros/patches-3.18/020-early-printk-support.patch
deleted file mode 100644
index bd937d34a6..0000000000
--- a/target/linux/atheros/patches-3.18/020-early-printk-support.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- /dev/null
-+++ b/arch/mips/ath25/early_printk.c
-@@ -0,0 +1,44 @@
-+/*
-+ * This file is subject to the terms and conditions of the GNU General Public
-+ * License. See the file "COPYING" in the main directory of this archive
-+ * for more details.
-+ *
-+ * Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
-+ */
-+
-+#include <linux/mm.h>
-+#include <linux/io.h>
-+#include <linux/serial_reg.h>
-+
-+#include "devices.h"
-+#include "ar2315_regs.h"
-+#include "ar5312_regs.h"
-+
-+static inline void prom_uart_wr(void __iomem *base, unsigned reg,
-+ unsigned char ch)
-+{
-+ __raw_writel(ch, base + 4 * reg);
-+}
-+
-+static inline unsigned char prom_uart_rr(void __iomem *base, unsigned reg)
-+{
-+ return __raw_readl(base + 4 * reg);
-+}
-+
-+void prom_putchar(unsigned char ch)
-+{
-+ static void __iomem *base;
-+
-+ if (unlikely(base == NULL)) {
-+ if (is_ar2315())
-+ base = (void __iomem *)(KSEG1ADDR(AR2315_UART0_BASE));
-+ else
-+ base = (void __iomem *)(KSEG1ADDR(AR5312_UART0_BASE));
-+ }
-+
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
-+ ;
-+ prom_uart_wr(base, UART_TX, ch);
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
-+ ;
-+}
---- a/arch/mips/ath25/Makefile
-+++ b/arch/mips/ath25/Makefile
-@@ -9,5 +9,8 @@
- #
-
- obj-y += board.o prom.o devices.o
-+
-+obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-+
- obj-$(CONFIG_SOC_AR5312) += ar5312.o
- obj-$(CONFIG_SOC_AR2315) += ar2315.o
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -106,6 +106,7 @@ config ATH25
- select SYS_HAS_CPU_MIPS32_R1
- select SYS_SUPPORTS_BIG_ENDIAN
- select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_HAS_EARLY_PRINTK
- help
- Support for Atheros AR231x and Atheros AR531x based boards
-