aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2008-05-13 04:20:47 +0000
committerTravis Kemen <thepeople@openwrt.org>2008-05-13 04:20:47 +0000
commitdeee32043aa8799c4441e0022f94b66cf9851c69 (patch)
treefe7bafaccbf1ecdb7b2e5c487a781bdc5dc4dd45 /target/linux/atheros/image
parenta1f7c05bbf540fc9f260b229a9caf58d5b42d088 (diff)
downloadmaster-187ad058-deee32043aa8799c4441e0022f94b66cf9851c69.tar.gz
master-187ad058-deee32043aa8799c4441e0022f94b66cf9851c69.tar.bz2
master-187ad058-deee32043aa8799c4441e0022f94b66cf9851c69.zip
revert to before ubnt images were made
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11130 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/image')
-rw-r--r--target/linux/atheros/image/Makefile20
1 files changed, 0 insertions, 20 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 7b035a6a8b..d50cae5049 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -22,26 +22,6 @@ endef
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
-
- echo -en "kernel\t\t0x01\t0xBE030000\t0x" > $(BIN_DIR)/ls5-parts
- echo -en "$(shell printf "%08X\n" $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c))" >> $(BIN_DIR)/ls5-parts
- echo -e "\t0x80041000\t0x80041000\t$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" >> $(BIN_DIR)/ls5-parts
- echo -en "rootfs\t\t0x02\t0x" >> $(BIN_DIR)/ls5-parts
- echo -en "$(shell printf "%08X\n" $(shell expr $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) + 3187867648 ) )" >> $(BIN_DIR)/ls5-parts
- echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3735552 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls5-parts
- echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls5-parts
-
- echo -en "kernel\t\t0x01\t0xBFC30000\t0x" > $(BIN_DIR)/ls2-parts
- echo -en "$(shell printf "%08X\n" $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c))" >> $(BIN_DIR)/ls2-parts
- echo -e "\t0x80041000\t0x80041000\t$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" >> $(BIN_DIR)/ls2-parts
- echo -en "rootfs\t\t0x02\t0x" >> $(BIN_DIR)/ls2-parts
- echo -en "$(shell printf "%08X\n" $(shell expr $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) + 3217227776 ) )" >> $(BIN_DIR)/ls2-parts
- echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3866624 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls2-parts
- echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls2-parts
-
- $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls2-parts -v XS2.ar2316.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
- $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls5-parts -v XS5.ar2313.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
- rm $(BIN_DIR)/ls2-parts $(BIN_DIR)/ls5-parts
endef
$(eval $(call BuildImage))