aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-2.6.25/007-mtd-partition.patch
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2008-07-04 16:05:00 +0000
committerHamish Guthrie <hcg@openwrt.org>2008-07-04 16:05:00 +0000
commit12fb2d89b47a5004e00eb6fea320ea787fef860f (patch)
tree5d3d2a0982f43ee2ec89badb8ffa39968e1d1dcb /target/linux/at91/patches-2.6.25/007-mtd-partition.patch
parentd8fac7f5f8a903a6ea6691e306a55270ed662094 (diff)
downloadmaster-187ad058-12fb2d89b47a5004e00eb6fea320ea787fef860f.tar.gz
master-187ad058-12fb2d89b47a5004e00eb6fea320ea787fef860f.tar.bz2
master-187ad058-12fb2d89b47a5004e00eb6fea320ea787fef860f.zip
First stage of update for at91 devices to 2.6.25.10 kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11631 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/patches-2.6.25/007-mtd-partition.patch')
-rw-r--r--target/linux/at91/patches-2.6.25/007-mtd-partition.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/at91/patches-2.6.25/007-mtd-partition.patch b/target/linux/at91/patches-2.6.25/007-mtd-partition.patch
new file mode 100644
index 0000000000..5c0cd3ec62
--- /dev/null
+++ b/target/linux/at91/patches-2.6.25/007-mtd-partition.patch
@@ -0,0 +1,42 @@
+Index: linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
+===================================================================
+--- linux-2.6.22.19.orig/drivers/mtd/devices/at91_dataflash.c
++++ linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
+@@ -175,7 +175,7 @@ static struct mtd_partition static_parti
+ };
+ #endif
+
+-static const char *part_probes[] = { "cmdlinepart", NULL, };
++static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
+
+ #endif
+
+Index: linux-2.6.22.19/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.22.19.orig/drivers/mtd/Kconfig
++++ linux-2.6.22.19/drivers/mtd/Kconfig
+@@ -168,6 +168,12 @@ config MTD_AFS_PARTS
+ the partition map from the children of the flash node,
+ as described in Documentation/powerpc/booting-without-of.txt.
+
++config MTD_AT91_PARTS
++ tristate "Atmel AT91 partitioning support"
++ depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
++ ---help---
++ Atmel AT91 partitioning support
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+Index: linux-2.6.22.19/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.22.19.orig/drivers/mtd/Makefile
++++ linux-2.6.22.19/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
++obj-$(CONFIG_MTD_AT91_PARTS) += at91part.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o