aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/patches
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-05-04 11:29:40 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-05-04 11:29:40 +0000
commitad6c3b6fef3328eca2f0752b4d0a00aeb9f4de45 (patch)
tree495c9a51f2b3866d4dcd7ba57decf71b74d93f3f /target/linux/at91-2.6/patches
parent7063e86d7401779b5d5be93aea326710939f9d14 (diff)
downloadmaster-187ad058-ad6c3b6fef3328eca2f0752b4d0a00aeb9f4de45.tar.gz
master-187ad058-ad6c3b6fef3328eca2f0752b4d0a00aeb9f4de45.tar.bz2
master-187ad058-ad6c3b6fef3328eca2f0752b4d0a00aeb9f4de45.zip
Changed partitioning not to use at91part.c as opposed to using
command-line partitioning. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7089 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/patches')
-rw-r--r--target/linux/at91-2.6/patches/007-mtd-partition.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/patches/007-mtd-partition.patch b/target/linux/at91-2.6/patches/007-mtd-partition.patch
new file mode 100644
index 0000000000..7b4efe5ed9
--- /dev/null
+++ b/target/linux/at91-2.6/patches/007-mtd-partition.patch
@@ -0,0 +1,36 @@
+--- linux-2.6.19.2.old/drivers/mtd/devices/at91_dataflash.c 2007-05-01 13:08:03.000000000 +0200
++++ linux-2.6.19.2/drivers/mtd/devices/at91_dataflash.c 2007-05-03 09:01:37.000000000 +0200
+@@ -146,7 +146,7 @@
+ };
+ #endif
+
+-static const char *part_probes[] = { "cmdlinepart", NULL, };
++static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
+
+ #endif
+
+--- linux-2.6.19.2.old/drivers/mtd/Kconfig 2007-05-01 13:08:02.000000000 +0200
++++ linux-2.6.19.2/drivers/mtd/Kconfig 2007-05-03 08:58:12.000000000 +0200
+@@ -157,6 +157,12 @@
+ for your particular device. It won't happen automatically. The
+ 'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
+
++config MTD_AT91_PARTS
++ tristate "Atmel AT91 partitioning support"
++ depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
++ ---help---
++ Atmel AT91 partitioning support
++
+ comment "User Modules And Translation Layers"
+ depends on MTD
+
+--- linux-2.6.19.2.old/drivers/mtd/Makefile 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2/drivers/mtd/Makefile 2007-05-03 09:00:00.000000000 +0200
+@@ -12,6 +12,7 @@
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
++obj-$(CONFIG_MTD_AT91_PARTS) += at91part.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o