aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/u-boot/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-20 09:59:17 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-20 09:59:17 +0000
commitce65b07441aa8bd6efb9908991b1b50cdf8d9781 (patch)
tree18df426a0f5674776b7ad0d177c8abf178812f58 /target/linux/at91-2.6/image/u-boot/Makefile
parent0dc6f05b1c4a1e40d1a021ed46aeaac256c70ecc (diff)
downloadmaster-187ad058-ce65b07441aa8bd6efb9908991b1b50cdf8d9781.tar.gz
master-187ad058-ce65b07441aa8bd6efb9908991b1b50cdf8d9781.tar.bz2
master-187ad058-ce65b07441aa8bd6efb9908991b1b50cdf8d9781.zip
Added primary and secondary bootloaders
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6626 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/image/u-boot/Makefile')
-rw-r--r--target/linux/at91-2.6/image/u-boot/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/image/u-boot/Makefile b/target/linux/at91-2.6/image/u-boot/Makefile
new file mode 100644
index 0000000000..4584f20f8b
--- /dev/null
+++ b/target/linux/at91-2.6/image/u-boot/Makefile
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=1.1.4
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/package.mk
+
+UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_UBOOT_TARGET)))
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+ export CROSS_COMPILE=$(TARGET_CROSS); \
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/InstallDev
+ dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(PKG_BUILD_DIR)/u-boot.block bs=232k count=1 conv=sync
+# mv $(PKG_BUILD_DIR) $(KERNEL_BUILD_DIR)/$(PKG_NAME)
+endef
+
+$(eval $(call Build/DefaultTargets))