aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/u-boot/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-04-05 13:23:15 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-04-05 13:23:15 +0000
commit1358c804e7a1ababd4541c9360995158ef2e1307 (patch)
treec1944c0cde5a12e23ffb88141e0537f086ffa85a /target/linux/at91-2.6/image/u-boot/Makefile
parent010a407a179a89724d88967b9e4d38395176ad46 (diff)
downloadmaster-187ad058-1358c804e7a1ababd4541c9360995158ef2e1307.tar.gz
master-187ad058-1358c804e7a1ababd4541c9360995158ef2e1307.tar.bz2
master-187ad058-1358c804e7a1ababd4541c9360995158ef2e1307.zip
Added module to generate u-boot config file. Added platform overrides
for base files. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6870 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/image/u-boot/Makefile')
-rw-r--r--target/linux/at91-2.6/image/u-boot/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/at91-2.6/image/u-boot/Makefile b/target/linux/at91-2.6/image/u-boot/Makefile
index 4584f20f8b..35b1e9bff1 100644
--- a/target/linux/at91-2.6/image/u-boot/Makefile
+++ b/target/linux/at91-2.6/image/u-boot/Makefile
@@ -27,11 +27,18 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
export CROSS_COMPILE=$(TARGET_CROSS); \
$(MAKE) -C $(PKG_BUILD_DIR)
+ mkdir -p $(PKG_BUILD_DIR)/ubclient
+ $(CP) ./ubclient/* $(PKG_BUILD_DIR)/ubclient
+ $(MAKE) -C $(PKG_BUILD_DIR)/ubclient \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(BOARD)=1"
endef
define Build/InstallDev
dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(PKG_BUILD_DIR)/u-boot.block bs=232k count=1 conv=sync
-# mv $(PKG_BUILD_DIR) $(KERNEL_BUILD_DIR)/$(PKG_NAME)
+# $(INSTALL_DIR) $(STAGING_DIR)/ubclient/sbin
+# $(INSTALL_BIN) $(PKG_BUILD_DIR)/ubclient/ubpar $(STAGING_DIR)/ubclient/sbin/
+ $(CP) $(PKG_BUILD_DIR)/ubclient/ubpar ../../base-files/default/sbin
endef
$(eval $(call Build/DefaultTargets))