aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/dfboot/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-06-04 17:41:40 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-06-04 17:41:40 +0000
commit3dd37ea0658ef033aa1bc20963e03e14b9b6e512 (patch)
treea4ab8182d1030b4c22537e63b29c11a901f9caaf /target/linux/at91-2.6/image/dfboot/Makefile
parentd69aa84e3017e59c29ff7e0d4f55b6bb60932e7d (diff)
downloadmaster-187ad058-3dd37ea0658ef033aa1bc20963e03e14b9b6e512.tar.gz
master-187ad058-3dd37ea0658ef033aa1bc20963e03e14b9b6e512.tar.bz2
master-187ad058-3dd37ea0658ef033aa1bc20963e03e14b9b6e512.zip
add new dfboot loader - a complete revison of romboot code.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7492 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/image/dfboot/Makefile')
-rw-r--r--target/linux/at91-2.6/image/dfboot/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/image/dfboot/Makefile b/target/linux/at91-2.6/image/dfboot/Makefile
new file mode 100644
index 0000000000..355a4b540f
--- /dev/null
+++ b/target/linux/at91-2.6/image/dfboot/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=dfboot
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)"
+endef
+
+define Build/InstallDev
+ dd if=$(PKG_BUILD_DIR)/binary/dfboot.bin of=$(PKG_BUILD_DIR)/binary/dfboot.block bs=32k count=1 conv=sync
+endef
+
+$(eval $(call Build/DefaultTargets))