aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/aruba-2.6/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-20 18:51:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-20 18:51:23 +0000
commit3e50bc2fafc40c0673467851cbb4b651eea84263 (patch)
tree1933319dd8cc8d671983482408681408f7a86e9f /target/linux/aruba-2.6/image
parent69cec943fdb54533d19f16258b78d6c42d0afa6a (diff)
downloadmaster-187ad058-3e50bc2fafc40c0673467851cbb4b651eea84263.tar.gz
master-187ad058-3e50bc2fafc40c0673467851cbb4b651eea84263.tar.bz2
master-187ad058-3e50bc2fafc40c0673467851cbb4b651eea84263.zip
give Aruba some love - add support for the combined flash layout
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7283 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/aruba-2.6/image')
-rw-r--r--target/linux/aruba-2.6/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/aruba-2.6/image/Makefile b/target/linux/aruba-2.6/image/Makefile
index e486b30ef2..7773f6a49e 100644
--- a/target/linux/aruba-2.6/image/Makefile
+++ b/target/linux/aruba-2.6/image/Makefile
@@ -31,11 +31,18 @@ define Image/BuildKernel
endef
define Image/Build/jffs2-64k
- @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
+ @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
@cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
mv $(KDIR)/image.tmp $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin
endef
+define Image/Build/squashfs
+ @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
+ @dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin bs=64k conv=sync
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef