aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-07 20:11:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-07 20:11:43 +0000
commit3303e79b79227f6e9479946090260a4b4bc1b9c8 (patch)
treeb9b93b23c7fdbd4392b5c32e8cef559fdaee340d /target/linux/ar71xx
parent4a6a77ad8b26ab233adbe70683810f443acc6bbe (diff)
downloadmaster-187ad058-3303e79b79227f6e9479946090260a4b4bc1b9c8.tar.gz
master-187ad058-3303e79b79227f6e9479946090260a4b4bc1b9c8.tar.bz2
master-187ad058-3303e79b79227f6e9479946090260a4b4bc1b9c8.zip
kernel: update linux 3.3 to 3.3.5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31645 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch31
2 files changed, 1 insertions, 32 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index fa18d21a5b..c479a443e2 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.3.5
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch b/target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch
deleted file mode 100644
index e5807c71f4..0000000000
--- a/target/linux/ar71xx/patches-3.3/003-MIPS-ath79-fix-AR933X-WMAC-reset-code.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 51233d66e030239f99755b2983753eff9b748365 Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Wed, 14 Mar 2012 10:28:35 +0100
-Subject: [PATCH 04/47] MIPS: ath79: fix AR933X WMAC reset code
-
-The current code puts the built-in WMAC device of the
-AR933X SoCs into reset instead of starting it. This
-causes a hard lock on AR933X based boards when the
-wireless driver tries to access the device.
-
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
-Cc: stable@vger.kernel.org
-Cc: linux-mips@linux-mips.org
-Patchwork: https://patchwork.linux-mips.org/patch/3484/
-Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
----
- arch/mips/ath79/dev-wmac.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
---- a/arch/mips/ath79/dev-wmac.c
-+++ b/arch/mips/ath79/dev-wmac.c
-@@ -58,8 +58,8 @@ static void __init ar913x_wmac_setup(voi
-
- static int ar933x_wmac_reset(void)
- {
-- ath79_device_reset_clear(AR933X_RESET_WMAC);
- ath79_device_reset_set(AR933X_RESET_WMAC);
-+ ath79_device_reset_clear(AR933X_RESET_WMAC);
-
- return 0;
- }