aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-18 09:32:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-18 09:32:36 +0000
commit0ca317b3799721f711fee587c556adf4f72cc400 (patch)
treec6d8fbde25f291e123a89bd008d4b0cbaf8441a9 /target/linux/ar71xx
parentd172b85b4f6502c13dc13cdf9aed4069835aafdd (diff)
downloadmaster-187ad058-0ca317b3799721f711fee587c556adf4f72cc400.tar.gz
master-187ad058-0ca317b3799721f711fee587c556adf4f72cc400.tar.bz2
master-187ad058-0ca317b3799721f711fee587c556adf4f72cc400.zip
scripts/om-fwupgradecfg-gen.sh: add support for the MR600
Signed-off-by: Marek Lindner <lindner_marek@yahoo.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34233 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d3d483d88f..e212348509 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -681,12 +681,13 @@ endif
define Image/Build/OpenMesh
$(call MkuImageLzma,$(2))
-sh $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
- "$(BUILD_DIR)/om2p-fwupgrade.cfg" \
+ "$(4)" \
+ "$(BUILD_DIR)/fwupgrade.cfg-$(4)" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" \
"$(KDIR)/root.$(1)"
-sh $(TOPDIR)/scripts/combined-ext-image.sh \
"$(4)" "$(call factoryname,$(1),$(2))" \
- "$(BUILD_DIR)/om2p-fwupgrade.cfg" "fwupgrade.cfg" \
+ "$(BUILD_DIR)/fwupgrade.cfg-$(4)" "fwupgrade.cfg" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" "kernel" \
"$(KDIR)/root.$(1)" "rootfs"
endef