aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
commit61cb662a1010e7e908335216bff7805f8835f0ba (patch)
tree9b189021db2e7e6921ec103c46d3bbc2fa5285ca /target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch
parent396b2efaf57498e67231d65bd34205cbe6c647df (diff)
downloadmaster-187ad058-61cb662a1010e7e908335216bff7805f8835f0ba.tar.gz
master-187ad058-61cb662a1010e7e908335216bff7805f8835f0ba.tar.bz2
master-187ad058-61cb662a1010e7e908335216bff7805f8835f0ba.zip
ar71xx: add support for linux 4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48563 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch')
-rw-r--r--target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch b/target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch
new file mode 100644
index 0000000000..9d0d1db168
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.4/405-mtd-tp-link-partition-parser.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -196,6 +196,12 @@ config MTD_MYLOADER_PARTS
+ You will still need the parsing functions to be called by the driver
+ for your particular device. It won't happen automatically.
+
++config MTD_TPLINK_PARTS
++ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
++ depends on ATH79
++ ---help---
++ TBD.
++
+ comment "User Modules And Translation Layers"
+
+ #
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
+ obj-$(CONFIG_MTD_CYBERTAN_PARTS) += cybertan_part.o
+
+ # 'Users' - code which presents functionality to userspace.