aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-19 17:58:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-19 17:58:40 +0000
commited2bc20d7f7aab0886ccf8baf4141740c249f6a8 (patch)
tree2d67b9ac31f10f44186aa6ef9114bc8dc725c98c /target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch
parent625ac75f09f72d599c42b5a9f26374b84baafec7 (diff)
downloadmaster-187ad058-ed2bc20d7f7aab0886ccf8baf4141740c249f6a8.tar.gz
master-187ad058-ed2bc20d7f7aab0886ccf8baf4141740c249f6a8.tar.bz2
master-187ad058-ed2bc20d7f7aab0886ccf8baf4141740c249f6a8.zip
ar71xx: add 4.1 support
Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46426 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch')
-rw-r--r--target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch b/target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch
new file mode 100644
index 0000000000..2a8944300a
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -208,6 +208,7 @@ endif
+ #
+ libs-$(CONFIG_FW_ARC) += arch/mips/fw/arc/
+ libs-$(CONFIG_FW_CFE) += arch/mips/fw/cfe/
++libs-$(CONFIG_MYLOADER) += arch/mips/fw/myloader/
+ libs-$(CONFIG_FW_SNIPROM) += arch/mips/fw/sni/
+ libs-y += arch/mips/fw/lib/
+
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -982,6 +982,9 @@ config MIPS_MSC
+ config MIPS_NILE4
+ bool
+
++config MYLOADER
++ bool
++
+ config SYNC_R4K
+ bool
+