aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-21 17:47:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-21 17:47:15 +0000
commit48222aa3da1720266e778a16cdd975a8f896e5fe (patch)
treeb66e38d9adb7fc703bd859d53128f1466017e3c6 /target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch
parent5d734cf6e9ab4aa36b2b6516212b0e0959a6efae (diff)
downloadmaster-187ad058-48222aa3da1720266e778a16cdd975a8f896e5fe.tar.gz
master-187ad058-48222aa3da1720266e778a16cdd975a8f896e5fe.tar.bz2
master-187ad058-48222aa3da1720266e778a16cdd975a8f896e5fe.zip
ar71xx: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35728 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..f117133169
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.8/420-net-ar71xx_mac_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -5,7 +5,7 @@
+ config NET_VENDOR_ATHEROS
+ bool "Atheros devices"
+ default y
+- depends on PCI
++ depends on (PCI || ATH79)
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y
+ and read the Ethernet-HOWTO, available from
+@@ -67,4 +67,6 @@ config ATL1C
+ To compile this driver as a module, choose M here. The module
+ will be called atl1c.
+
++source drivers/net/ethernet/atheros/ag71xx/Kconfig
++
+ endif # NET_VENDOR_ATHEROS
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/