aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:33 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:33 +0000
commit40fe2e818c760cc908cdd4bc825e8c4f9d2dab04 (patch)
treee5733bc35dc8080ec5c18a72ffacafb444b21241 /target/linux/ar71xx/patches-3.18
parent2a04e78e1f1dbb37b8378bbcd783dd20dbd584c1 (diff)
downloadmaster-187ad058-40fe2e818c760cc908cdd4bc825e8c4f9d2dab04.tar.gz
master-187ad058-40fe2e818c760cc908cdd4bc825e8c4f9d2dab04.tar.bz2
master-187ad058-40fe2e818c760cc908cdd4bc825e8c4f9d2dab04.zip
ar71xx: add kernel support for EnGenius EPG5000.
Signed-off-by: Christian Beier <cb@shoutrlabs.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46047 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.18')
-rw-r--r--target/linux/ar71xx/patches-3.18/718-MIPS-ath79-add-EPG5000-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/718-MIPS-ath79-add-EPG5000-support.patch b/target/linux/ar71xx/patches-3.18/718-MIPS-ath79-add-EPG5000-support.patch
new file mode 100644
index 0000000000..579e024dfb
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/718-MIPS-ath79-add-EPG5000-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -196,6 +196,16 @@ config ATH79_MACH_F9K1115V2
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_EPG5000
++ bool "EnGenius EPG5000 board support"
++ select SOC_QCA955X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_ESR1750
+ bool "EnGenius ESR1750 board support"
+ select SOC_QCA955X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -69,6 +69,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2) += mach-eap300v2.o
+ obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
+ obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
+ obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o
++obj-$(CONFIG_ATH79_MACH_EPG5000) += mach-epg5000.o
+ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
+ obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
+ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -59,6 +59,7 @@ enum ath79_mach_type {
+ ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
+ ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
+ ATH79_MACH_ESR1750, /* EnGenius ESR1750 */
++ ATH79_MACH_EPG5000, /* EnGenius EPG5000 */
+ ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
+ ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */