aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
commitf15a427a56e713cb637aeb84349ba3fe02cfe9e6 (patch)
tree0456ec1a1feb352bd0481fba9936533f72be8c4d /target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch
parent40dfb136e7b97de923312603916abbab42c49757 (diff)
downloadmaster-187ad058-f15a427a56e713cb637aeb84349ba3fe02cfe9e6.tar.gz
master-187ad058-f15a427a56e713cb637aeb84349ba3fe02cfe9e6.tar.bz2
master-187ad058-f15a427a56e713cb637aeb84349ba3fe02cfe9e6.zip
ar71xx: add 2.6.39 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch b/target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch
new file mode 100644
index 0000000000..b733dff44f
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.39/207-rb750-led-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -394,6 +394,10 @@ config LEDS_WNDR3700_USB
+ This option enables support for the USB LED found on the
+ NETGEAR WNDR3700 board.
+
++config LEDS_RB750
++ tristate "LED driver for the Mikrotik RouterBOARD 750"
++ depends on LEDS_CLASS && AR71XX_MACH_RB750
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGER_TIMER
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -41,6 +41,7 @@ obj-$(CONFIG_LEDS_LT3593) += leds-lt359
+ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
++obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
+ obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
+ obj-$(CONFIG_LEDS_NETXBIG) += leds-netxbig.o
+